0
0

Hi:

I’m developing for a Smartphone running CE.NET (a pre-release, developer model) trying to make a game. I’m having a bunch of problems using version 3.60 of your library – I hope someone can take a look.

1) With the Smartphone and CE300 DLLs, I can load MP3s, but when I try to load a WAV I get an exception in the DLL.

2) With the MP3, I have a sample triggered off a WM_KEYDOWN message; the latency is up to 300ms. I have attempted to change the Buffer size (150, 200, 50) to no avail. I have also attempted to change the INIT frequency to 22050 and 32000, but there is no discernable effect.

3) The volume is really low. I have set the absolute volume and the SFX volume, but still the MP3 is barely audible through the built-in speaker. I know the device can produce louder sounds — is this maybe a hardware/OS change?

4) I tried changing the OUTPUT, to see whether that helped performance, but I got an exception from the DLL then as well.

Any suggestions are much appreciated. This is such a cool library; I hope I can make it work.

Thank you,
/m

  • You must to post comments
0
0

Brett:

It doesn’t seem to have much effect. I still find that volume is very low, latency for triggering sound effects is high, and the FSOUND_Init function is quite finicky – throws exceptions under many circumstances.

Anything else I should try?

Thank you,
/m

  • You must to post comments
0
0

Latency: When I use the standard, Pocket PC API “PlaySound”, my sfx sound instantly. When I use FSOUND_PlaySound, there is an audible lag of up to 300ms. Am I misusing FSOUND somehow? Do the default settings vary from PlaySound somehow?

I tried this code on a Pocket PC device and had the same results, so though it may be OS, it’s not new.

[b:jl6o6o14]Is anyone else using this library for game sound effects? Are you having the same delays? Any suggestions?[/b:jl6o6o14]

Thank you,
/m

  • You must to post comments
0
0

Sorry, Brett, I really meant no offense – PlaySound clearly cannot meet my requirements. I was using it simply as a test as to whether the device drivers were introducing the latency.

I have tried reducing the buffer size to 50 on Pocket PC, and it does make a big difference. Smartphone must have some OS issues that were causing it to throw those exceptions before. Let me know if you want any debugging info.

Is buffer the only value you’d change?

Thank you for your help,
/m

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.