This seems to be consistent across multiple machines, so I must be missing some flag or something: in games that make a ton of sounds at once (most likely too many to fit in the available channels), using just the most basic FMOD code to play sounds, once too many sounds occur, this sentence is really running on and on, the sound buffer starts hiccuping and echoing and turns into a big noisy mess. I think this occurs when I try to play one sound more than the maximum number of channels (I don’t know for sure though, and sometimes it seems like it happens with the first or second sound to be played). Is there something I should be doing differently?

I’m truly doing the basics:


Those aren’t really consecutive lines of code, but they show just how simple the FMOD portion of the code is. I haven’t actually tried using 44100 as the sampling rate, maybe that’s all there is to it. It just seems very strange to me that I can’t find this problem mentioned in these forums anywhere, and it appears to be consistent on all XP machines! So I hope I’m just missing some flag or something. Help?

  • You must to post comments

Well, I couldn’t make the simple example break, no matter what I did, so at the least, that’s a baseline I can compare to. I may have fixed it, by cutting the number of channels available (in this game, FSOUND_Init gave 65 channels, which I admit is a little extreme). We’ll see if it holds up over time, and maybe boosting the buffer size can save the day if it doesn’t. The game does do an awful lot of processing and the message pump may not be getting its due as a result. Doesn’t really explain the other game where it only had 32 channels, but I already released that one without FMOD, so I won’t worry about it! Thanks.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.