0
0

My player is playing 24/7 and sometimes if I list /proc/%d/fd I can see some file descriptors that points to songs which played few hours ago.
I’m using fmod 3.61.
There’s no errors, everything is ok but descriptors are still open. Why? Bug?
Here is example :
lrwx—— 1 linda linda 64 Vel 17 15:23 0 -> /dev/pts/2
lrwx—— 1 linda linda 64 Vel 17 15:23 1 -> /dev/pts/2
l-wx—— 1 linda linda 64 Vel 17 15:23 10 -> /dev/dsp0
lr-x—— 1 linda linda 64 Vel 17 15:23 11 -> pipe:[3531356]
l-wx—— 1 linda linda 64 Vel 17 15:23 12 -> pipe:[3531356]
l-wx—— 1 linda linda 64 Vel 17 15:23 13 -> /dev/dsp1
lrwx—— 1 linda linda 64 Vel 17 15:23 14 -> socket:[3531358]

lr-x—— 1 linda linda 64 Vel 17 15:23 15 -> /mp3/faith_hill-this_kiss.mp3
// This one played around 6 hours ago

lr-x—— 1 linda linda 64 Vel 17 15:23 16 -> /mp3/MojoClub/Dancefloor Jazz Vol. 3/19 – odyssey – our lives are shaped by what we live.mp3
//This one played around 5 hours ago
lr-x—— 1 linda linda 64 Vel 17 15:23 17 -> /mp3/drevil.mp3
// This one played two hours ago (drevil.mp3)
lr-x—— 1 linda linda 64 Vel 17 15:23 19 -> /mp3/Bohemian rhapsody.mp3
// This one is playing at this moment
lrwx—— 1 linda linda 64 Vel 17 15:23 2 -> /dev/pts/2
lr-x—— 1 linda linda 64 Vel 17 15:23 20 -> /mp3/destinys_child/survivor/fancy.mp3
// This one is playing on second soundcard
lrwx—— 1 linda linda 64 Vel 17 15:23 3 -> /dev/pts/2
lr-x—— 1 linda linda 64 Vel 17 15:23 4 -> pipe:[3531349]
l-wx—— 1 linda linda 64 Vel 17 15:23 5 -> pipe:[3531349]
lrwx—— 1 linda linda 64 Vel 17 15:23 6 -> socket:[3531350]
lr-x—— 1 linda linda 64 Vel 17 15:23 7 -> pipe:[3531352]
l-wx—— 1 linda linda 64 Vel 17 15:23 8 -> pipe:[3531352]
lrwx—— 1 linda linda 64 Vel 17 15:23 9 -> socket:[353135

Sometimes after while application hangs , I didn’t know why but I’m suspicious on lot of file descriptors open.
Any idea ?

  • You must to post comments
0
0

I’ve found why fmod don’t close fd’s…eg:
I have an mp3 (which play in xmms w/o any problems) ….and it’s length is
01:47…but fmod says that it’s length is 02:38 !?! (of course measures are maded in ms , just translated into mm:ss…so what’s up with fmod’s
FSOUND_Stream_GetTime (stream) and FSOUND_Stream_GetLengthMs(stream) ? So when song come to 1:47 but fmod leave descriptor opened for unknown reason (maybe waits end at 02:38) but it cannot reach the end because song already finished.

  • You must to post comments
0
0

use the FSOUND_MPEGACCURATE flag in the FSOUND_Stream_OpenFile func.

  • You must to post comments
0
0

hmm….I’ve played a bit with FSOUND_MPEGACCURATE (it was on all the time) so :

When I say FSOUND_NORMAL or FSOUND_MPEGACCURATE it plays ok but eg. song which length is around 20 minutes needs almost a second to start play.

Same thing with just FSOUND_MPEGACCURATE …. BUT when I say
FSOUND_NORMAL AND FSOUND_MPEGACCURATE it plays fast as hell and there I’ll reach problems with some songs (most of them play ok).

I’m using linux with 2.4.21-pre4 kernel and Kylix 3.

  • You must to post comments
0
0

mmmhhh can it be a slowdown in the linux sound driver ? Brett ? :)

  • You must to post comments
0
0

I’ve tried this with same machine PII 1200 512Mb Ram 2xMaxtor 40Bg , 7200 rpm UATA 100 on promise raid on this soundcards :

1.SoundBlaster PCI 128 es1371
2.SoundBlaster Live
3.Terratec DMX1024 Fire

Always same results…and I’m using Alsa with OSS emulation.

  • You must to post comments
0
0

This , about file descriptors is story about bad length time from mp3’s.
example : With xmms song plays ok and have length eg. 10000 ms, but when plays with fmod , it says length is eg. 19000 ms so when song come to 10000 it doesn’t call callback since fmod thinks that real end is at 19000.
This happens if I’m using FSOUND_NORMAL AND FSOUND_MPEGACCURATE , but when using FSOUND_NORMAL OR FSOUND_MPEGACCURATE then everything is OK.I’ve found just two such songs in my collection (1200 songs at the moment).

I didn’t change freq.
By “fast as hell” I mean -> it starts like it should :)…I have one song from Nirvana, and it’s length is more than 20 minutes.With FSOUND_NORMAL AND FSOUND_MPEGACCURATE it starts immediatly, but with FSOUND_NORMAL OR FSOUND_MPEGACCURATE it needs more than one second to start.
That’s my problem :)
I don’t want “diesel” engine :)

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.