0
0

I concluded that the FSOUND_CD_SetVolume affects the “system CD volume control”, in reality it’s impossible to connect your 2 or more CD devices to 1 system volume control.
Second I only can have access to my default CD device when the parameter “char drive” in for example “FSOUND_CD_SetVolume(char drive, int volume) is set to “0”.
When I try to set this parameter to “G” or “H” there is no reaction on my CD devices.

Best Regards,

Tony

  • You must to post comments
0
0

I just found a solution to get access to CD devices other then the default device 0 (for Visual Basic).

As described in the documentation to use ‘D’ or ‘E’ can’t be used in VB.
Instead of ‘D’ or ‘E’ you can use Asc(“D”) or Asc(“E”) to get access to drive D: or E:

Best Regards

Tony

  • You must to post comments
0
0

The problem that the FSOUND_CD_SetVolume still can just set the volume of the device wich is connected to the “system CD Volume control”

Best Regards

Tony

  • You must to post comments
0
0

Thanks, when I set my system to “Enable digital CD audio for this CD-ROM device” then it works fine.
But I’m using also 2 soundcards on my system.
For streaming audio the “system volume control” is not used to set the volume on one or more channels.
For MP3 (stream) audio, I can choose an audiodevice (soundcard) in the FMOD initialization to play the music trough.
This setting does not affect the CD playback audiodevice.
Is there another way to do so?

Best Regards

Tony

  • You must to post comments
0
0

This is because FMOD never plays CDs digitally (i.e. rip n’ play); instead it goes through MCI. When a disc is played through MCI, the drive does all the reading and playing, so the sound comes from whichever soundcard the drive is internally attached to.

Note that FMOD 4 has planned support for digital playing.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.