0
0

I am using an SB Live! audio card. I want to play an MP3 on the front audio outputs and another MP3 on the rear audio outputs. Is this possible? If so how do I accomplish this? Thanks!

  • You must to post comments
0
0

I do not think that is possible.

  • You must to post comments
0
0

If you are happy with Mono, there is no problem at all.
Just open your MP3 as a stream with flags FSOUND_HW3D and FSOUND_FORCEMONO and then play it in 3D.
You can set the position to (1,0,0) for front and (-1,0,0) for rear.
It might be that it is the last number for front/rear, you should just try…

  • You must to post comments
0
0

Thanks for all of the replies! I accomplished this using Samples and .wav files but could not get the Sample_Load() to work with a .mp3 file and the FSOUND_HW3D flag. I guess I’ll try it the stream way since that seems to be what everyone was suggesting. Thanks for the help and any more information would be greatly appreciated!

  • You must to post comments
0
0

Okay I am not having good results using Streams!

This works:
g_pStream = FSOUND_Stream_OpenFile(“test.wav”, FSOUND_HW3D | FSOUND_MONO | FSOUND_LOOP_NORMAL, 0);

Works but when I try it using this it does not:
g_pStream = FSOUND_Stream_OpenFile(“front.mp3”, FSOUND_HW3D | FSOUND_MONO | FSOUND_LOOP_NORMAL, 0);

The only difference in the two calls is the is the file name. I get the error message “Error creating hardware sound buffer.”. Can I still use the 3D positional features of FMOD without a hardware 3D sound buffer?

WAV Stats –
Bit Rate:88kbps
Sample Size:8bit
Channels:1(mono)
Audio Sample Rate:11kHz
Audio Format:PCM
File Size:245KB

MP3 Stats –
Bit Rate:128kbps
Channels:2(stereo)
Audio Sample Rate:44kHz
File Size:682KB

This is my init call:
FSOUND_Init(44100, 128, 0)

Is there anything I am doing wrong? Thanks for any suggestions/tips/help!

  • You must to post comments
0
0

As stated on the front page, since DirectX 8 it is not possible to play stereo files in 3D mode anymore. The difference between your wav and your mp3 is your wav is mono and your mp3 is stereo.
If you use fmod v3.4 you can kind of overcome this problem by adding the FSOUND_FORCEMONO flag, which converts stereo streams to mono. It takes a little more processing time AND you lose stereo, but at least you can freely position you mp3’s :smile:

A great feature for v3.5 to solve this would be that you could specify wether FORCEMONO uses the LEFT, the RIGHT or both channels.
This way you could play your stream twice, and position one rear-left and the other rear-right.
Currently you’ll have to use MONO though…

  • You must to post comments
0
0

Oh, forgot to mention it…
When I first heard you could not play stereo streams in 3D, I also tried to use FSOUND_MONO, but this flag is only valid for creating new samples/streams I think.
That’s why brett added FSOUND_FORCEMONO, which converts existing streams to MONO.

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.