0
0

Does anyone know if there is some setting in Windows XP (pro) that causes the sound output to mute when a top level window loses focus?

I have a player I wrote using FMOD that has been working perfectly under NT4 for a year.

On trying to use it under XP pro, it starts playing correctly when I select a track, but as soon as I switch to another task, the output stops.

Any help appreciated.

Mogul

  • You must to post comments
0
0

This is not an error; it’s correct DirectSound behavior. In NT4, FMOD defaults to using WinMM for sound output, so you don’t get this. But under Windows 9x and 2K/XP, FMOD uses DirectSound by default, which will mute the sound if the your application loses focus. To negate this behavior, add the FSOUND_INIT_GLOBALFOCUS flag to your FSOUND_Init line.

  • You must to post comments
0
0

Thanks Bruce that worked a treat. Sorry to waste your time, I’d assumed it was some devious windows switch and didn’t even look at the FMOD documentation – doh!

Mogul

  • You must to post comments
0
0

Waste my time? Impossible. I’ve been keeping my skills to myself long enough; it’s time I finally started helping out the community.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.