0
0

Hi

I downloaded a midi file a while ago (the imfamous e1m1 from the original doom) and the only player i can find that will play it back properly is windows media player.

i tried the fmod player (i want to play it in a demo i’m making) but for some reason it seems to skip out every other note.

any suggestions why? i’ve uploaded the midi file so you can test it yourself

http://remnant.gamedev.net/doom.mid

also, every converter i’ve tried (to either wave or mod) completely messes up. the best one i’ve found so far is called Modplug Tracker – the left channel comes out alright but the right one is full of noise!

  • You must to post comments
0
0

Midi files depend on the soundcard capabilities and the soundbank you use. By default, Windows Media Player use the Microsoft Synthesizer but FMOD use the midi output you have selected in your sound configuration (in the soundcard configuration panel).

  • You must to post comments
0
0

[quote="KarLKoX":2eqbc8ax]Midi files depend on the soundcard capabilities and the soundbank you use. By default, Windows Media Player use the Microsoft Synthesizer but FMOD use the midi output you have selected in your sound configuration (in the soundcard configuration panel).[/quote:2eqbc8ax]

okay, at the moment windows media player uses whatever i set MIDI playback in the Sounds and Multimedia dialog in the control panal (Audio Tab, MIDI music playback).

I currently have it set to SB Live! Synth A, which produces the correct results in media player.

When i change these over, media player reacts accordingly (actually, they all produce the same sounds apart from the SB Live! MIDI port which obviously plays nothing through the speakers as i have no keyboard connected).

the FMOD player (in the samples directory) will play the midi at exactly the same quality regardless of what i have selected, even if it’s the MIDI port.

any other ideas?

  • You must to post comments
0
0

Try with the FSOUND_INIT_USEDEFAULTMIDISYNTH flag :)

  • You must to post comments
0
0

i tried that and it didn’t make a difference.

any way of making fmod use media player’s decoder (whatever it is it uses, it’s damn good!)

it seems as if the notes arn’t playing for as long as they should do. The notes in that midi file are actually quite long and seem to overlap each other, while every other midi player will only play one note at a time instead of blending them together.

i’ll try and link my mic input to speaker output and record what it should sound like.

  • You must to post comments
0
0

My speaker wire is moulded to the sub so i can’t swap them around.

argh!

  • You must to post comments
0
0

how do i check that?

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.