0
0

hi,
i try to record something, and show the VU. i read the docu and noticed that i have to create a sample.

so, i have to set the lenght in sampels but i have no idea what the hell a sample is!

and, once i created a sample, i just have to start recording?!?!

and playback some ms later, to get a safe distance between the pointers?

maybe someone could give the basic code-lines (vb)

thx a lot!

Mad

  • You must to post comments
0
0

ok, i try it this way:

SamplePointer = FSOUND_Sample_Alloc(0, 1, 0, 22050, 0, 128, 0)
FSOUND_Record_StartSample SamplePointer, True
Sleep 10
FSOUND_PlaySound 1, SamplePointer

but ehm, not really working.
what i’m doning wrong?

Mad

  • You must to post comments
0
0

i init fmod, so i can play sound. do i have to init the record driver also?

Mad

uh, i should stop talking to myself *g *

  • You must to post comments
0
0

hey, this ‘talking to oneself’ is great! just found some bugs, my code is right now:

SamplePointer = FSOUND_Sample_Alloc(FSOUND_UNMANAGED, 22050, FSOUND_MONO Or FSOUND_16BITS, 22050, 255, 128, 255)
FSOUND_Record_StartSample SamplePointer, True
Sleep 100
FSOUND_PlaySound 1, SamplePointer

so, the samples are the length * freq. i looked in the c++ source.

okok, but still getcurrentvu gives me 0.

WHY?

Mad
hopefully the next post will be of someone else 😉

  • You must to post comments
0
0

WTF!!!

i init fmod, no errors.
i get the drivetlist and ‘record_setdriver’ returns 1, True, no errors-
i create a sample (sampleAlloc), get a pointer.

now i record into this sample (record_startsample) but getposition alway returns 0

whts going wrong???????

😡

  • You must to post comments
0
0

OH FFFFFFUUUUUCCC*************!!!!
banging my head against a wall

just a damn typingerror when setting the recordingdevice.

i setted it maualy and it worked.
have to go earlier to bed…

sorry,

Mad

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.