0
0

Hi,
I get sound distortion when I play samples in FMOD in my application. I’ve tried both version 3.60 and 3.70, the same problem in both. I load the samples from wave files and I’ve tried to resample them and tried both 8- and 16-bit bitdepth but nothing helps. I also tried to lower the volume.
I’ve tried to use 22050, 44100, 48000 as well as other settings for FSOUND_Init and I also tried to resize the buffer. Nothing works! The weird thing is that the sample apps followed by FMOD doesn’t appear to have this problem. No other applications I’ve ran on this computer have this problem either. The application uses DirectX but that shouldn’t be a problem.
The problem only appear with non-smooth sounds, sine waves sounds great, explosions crackle very much.
Does anyone have any idea why this happends?
BTW. I have an nForce motherboard with built-in sound card.

  • You must to post comments
0
0

I’m pretty sure it is not buffer underrun, the sounds are audiable all the time but they sound very bad. But if FMOD really gets too little CPU time, what can be done about it? I call Sleep(0) in every cycle of the program (Yes, it is a game) but that doesn’t seem to help.
In the FMOD player, the samples sound as they should sound. It can’t really be clipping since I have tried to lower the volume on all sounds and the error stays unaffected, except with lower volume. I first thought that it was a driver issue but updating drivers doesn’t affect the error. A few others have pointed out the same problem with the application but not everybody seem to have the problem.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.