0
0

We’ve got audio files currently playing across a network from a server, typically WAV PCM or WAV IMA ADPCM. When we copy files to the server from another machine at the same time, it obviously ties up the hard disk and sometimes the network resulting sampling/stuttering.
We tried the same thing out with winamp and it was okay.

I believe that the default is a small buffer of 50ms. As we’re merely playing straight forward audio to particular sound devices/outputs (ie without fx or dsp etc) I would have thought increasing the buffer size would be okay and would sort the problem.

We attempted to increase the setbuffersize to 2000 ms but it meant that when we played it, there would be 2 seconds of silence before audio came in, which was rather strange…

Is there a way of doing it whereby it does what it’s supposed to? We must be doing something wrong somewhere…

  • You must to post comments
0
0

Why are you setting the buffersize so high? Have you tried maybe a buffersize of 200 or 300?

  • You must to post comments
0
0

I think you’re using FSOUND_SetBufferSize when you should be using FSOUND_Stream_SetBufferSize.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.