0
0

I am trying to load some .wav and .mp3 files (they are about as big as most songs tend to be). I specify FSOUND_HW3D when loading a stream with FSOUND_Stream_Open. Everything loads fine without it. I can use looping and that works. The one variable that throws everything off is FSOUND_HW3D. If I load a very small file, I am able to get away with FSOUND_HW3D. Finally, I am able to specify FSOUND_HW2D! My question is why might it be doing this? 3D calculcations are generally independent of the file size right?

I tried specifying 0 for the FSOUND_SetMinHardwareChannels, to get everything calculated in software, but I know that function is really for play-time functionality when channels are allocated. It didn’t work anyway.

I hope my question was clear enough. Thanks in advance for anyone who may have advice, knowledge, or suggesetions on this issue.

  • You must to post comments
0
0

Thanks Brett – you guys are awesome at support. The FORCEMONO option fixes it. The fMod documentation says that 3D calculations can be done in software if necessary…

  1. Does the MONO restriction extend to software calculations as well.

  2. Is there any way to explicity specify that 3D calculations get done in software? Would SetMinHardwareChannels(0) do this?

Thanks

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.