0
0

Hello all,
I need to make particular sounds use the software 3d system whilst most use hw3d. I need this because I can’t set negative frequencies on hw3d sounds with fmod3.7 and an sblive :( I need to have most sounds using hw3d because our game (acmi_park) makes fairly heavy use of eax.
So I need the equivalent of FSOUND_3D as opposed to FSOUND_HW3D. It seems as though this flag exists, because 3d software sounds do not have the FSOUND_HW3D flag set (on linux with fmod3.63 at any rate).
I’ve tried just using FSOUND_2D and setting the position and velocity vectors, but the result is a 2d sound.

Thanks for any help

  • You must to post comments
0
0

Don’t specify any of those flags. By default, a sample will be created in software and is able to be positioned in 3d e.g. :

FSOUND_Sample_Load(FSOUND_FREE, “blah.wav”, 0, 0, 0);

  • You must to post comments
0
0

Thanks Andrew, it works. I see it is implied in the fmod header file too. Perhaps it should be put in the docs.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.