I’ve noticed that midi doesn’t seem to work with the newest version of FMOD.

I thought it might be my code for my program. But I looked over it and since mods played fine, I couldn’t understand why midi wasn’t working.

I tryed with various midi files, not which worked. (But they all worked with version 3.63, I tested the same code with both 3.63 and 3.70)

So then I decided to check the format in the actual 3.70 fmod player you have, and to my surprise it didn’t work either.

Was this format dropped, not supported anymore? or is this a “bug” with the newest version of FMOD (3.70)?


EDIT: This was with the FMUSIC system, but I did notice that it does allow you to STREAM the mid format (athough, there is no sound output)

  • You must to post comments

Ok, it works now. I guess I’ll just have to remember to set the flag from now on.

Thanks for the reply.

EDIT [October 17, 2003]:

hmm, there seems to be a significant difference between Fmod 3.70 and the second bug fixed 3.70 when it comes to the midi format.

Fmod 3.70 (original):

-Midi doesn’t load into FMUSIC, instead it loads as a stream…
(At least my code is setup so that if it can’t load in FMUSIC, to try streaming.)
-Can’t be heard unless you set the Use Default Midi Synth flag…
-Couldn’t use FMUSIC functions at all (since it loaded as a stream)

Fmod 3.70 (bug/tag fixed version):

-Loads correctly into the FMUSIC system (like it is supposed to)
-Doesn’t require the Use Default Midi Synth flag to be set anymore…
-Certian FMUSIC functions still don’t seem to work with midi

Did you change anything with midi playback with the new 3.70 bug update besides the way tags are delt with? Would seem kinda odd that changing the way tags are delt with would effect the midi support.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.