0
0

I had fmod working great in my project on a few older development machines, but now I’m working on my project on my laptop a lot, which has Panther and Xcode installed. So, when linking with gcc 3.3, I get the following linker errors:

multiple definitions of symbol std::exception::~exception [in-charge deleting]()
multiple definitions of symbol std::exception::what() const
multiple definitions of symbol std::bad_exception::~bad_exception [in-charge deleting]()
multiple definitions of symbol std::__throw_bad_alloc()

… and a whole slew of other multiple definition errors. I usually see these kinds of linker errors on other platforms when I am working with libraries that were compiled on different versions of the compiler, so I don’t know if that’s the issue we’re dealing with. I’ve tried compiling with gcc 3.1 and gcc 2.95.2 and neither of those work either (I get other multiple definitions errors… 2.95.2 only gets one multiply defined symbol: _throw()).

Anyone using Xcode and Panther out there know how to get this to work? I’m planning on upgrading all of my development machines to Xcode and Panther ASAP and don’t want it to affect our project much.

If it is a compiler-versioning issue of sorts, can I expect an update to fmod anytime that was compiled using gcc 3.3, since that’s what Apple is pushing now?

Oh, and I also would really love to see a framework version of fmod. I’d be happy to build one if you need someone to put it together.


Alexander Powell
alex [at] powelltown [dot] com
Georgia Institute of Technology – Studio 100

  • You must to post comments
0
0

[quote="brett":36s7ubti]try http://52.88.2.202/files/libfmod.a.sit and let me know what happens.[/quote:36s7ubti]

That’s great! And such a speedy response!

Thanks a bunch, Brett… I’ll be sure to let you know if we have any further problems, but sofar we have none.

  • You must to post comments
0
0

I’m working on a project with genekrupa, I’m using OSX 10.1.5 (gcc 2.95.2) at home, but doing primary development in a lab at school with 10.2.x. I had the problem with multiply defined _throw (on 10.1), and I tried using the new lib you posted here. Now I get undefined references to _istype and _toupper, which are in libfmod.a according to grep. I have tried looking for those in other libraries to see if I can get them defined, but nothing has worked.

This isn’t too pressing an issue, but I thought it might be useful for you to know if fmod is incompatible on some system. Let me know if you have a solution. Thanks.

-pwg

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.