0
0

Ok, I’ve just put up a beta version of the 3.71 media player so everyone can check out the new CDDA stuff. It’d be great if you could all download it, test the digital cd playback and post back here if you have any problems. Here’s the url:

[url:3n0zzs83]http://www.fmod.org/files/fmod371.zip[/url:3n0zzs83]

The interface has changed a bit. Hit ‘Load CD’ to populate the playlist with the currently loaded CD’s tracks then just play them as usual. Notice that the CD output now appears in the scope and spectrum. 😀

The Options dialog is now accessible through the system menu in the top left of the main window. Choose your CD drive letter here and also choose digital or analog playback. There’s also a big “Device Info…” button that will report a bunch of details on the currently selected CD device.

If you have problems with CDDA, get the device info and mail it to me at andrew@fmod.org – don’t post it here or the thread will get too cluttered. Don’t forget to include a description of the problem you encountered. This is definitely still a BETA release so don’t expect it to work perfectly – I just want to get it out asap so I can start hitting the inevitable compatibility issues that are bound to turn up.

Thanks for your help guys!

Cheers,

  • You must to post comments
0
0

I just tried it and it seems to be working really great.
I was also amazed about the speed you can seek in a cd track.

Only one small thing: playing a cd digital takes about 10 to 14% cpu on my athlon 1Ghz (an mp3 uses less than 1%)

  • You must to post comments
0
0

Ok, I sent you my device info report but when i test the debug version of the FMOD media player with jitter correction the CPU meter rises to about 91% and without jitter correction the CPU meter displayes over 100% :x. I hope the device info I sent you helps. It may be that the system i tested it on is just too old for the great power of FMOD, hehe.

  • You must to post comments
0
0

The CPU meter in the latest version seems to climb constantly while playing a CD track. It started at 0.5% and now it’s climbed to over 6%. Turning on the spectrum equalizer makes it fluxuate like nuts, it’s at 7.5% now. Doesn’t seem to ever get much higher than 7.5%, though. And it’s definitely wrong.

Taskman says it’s using less than 5% during its bursts, and most of the time it’s only using 0%.

The CD playback works flawlessly though. Excellent work.

BTW, the volume slider seems to default to 0%.

Playing a CD track using ASIO for output makes the spectrum analyzer and oscilliscope lag and update really slowly, but the CPU usage is still low. WaveOut and DiretSound are both very smooth in comparison. Any ideas there? (I have an audigy, so it’s using creative ASIO, fyi)

Oh, and this is fun. Set the output rate to 8khz and play a CD track… it sounds kind of cool :) I’m impressed, even DSP effects work at 8khz.

  • You must to post comments
0
0

With the new upload the cpu usage still increased rapidly but topped off at around 75%. There has to be other people experiencing this right? I hope I’m not the only person that has this problem, hehe. :roll:

  • You must to post comments
0
0

That CPU percentage is deceptive. At the moment it’s timing the CD read, which it shouldn’t be. The actual CPU time is very small given that there’s no decoding to do, it’s just straight 44100, 16bit stereo right off the CD. I’m looking into fixing that for the final release of 3.71. Realistically, CDDA is slightly more CPU intensive than analog playback, given that it’s going through the software mixer and not straight to your sound card, but it’s no more expensive than a normal uncompressed stream.

And the benefits are so worth it – FSOUND_SetFrequency, DSP units, synch callbacks, end callbacks. It’s all good fun. I’ve already written a new example program which rips CD tracks to wav. It’s a little over one page of C code. Easy peasy 😀

  • You must to post comments
0
0

Paranoid_Android, what are the specs of your system? CPU, OS, RAM etc. etc.

edit: Also, have you tried using any other CDDA ripping software? Did it work? Did it use ridiculous amounts of CPU time?

  • You must to post comments
0
0

The two drives are CDDA enabled.

I already encoded, in MP3, a track of a CD, using Audio Converter 4, and all was working correctly.

  • You must to post comments
0
0

No you’re not the only person, still go to 50%…

  • You must to post comments
0
0

I always get an error when I press the “Load CD” button: “ERROR: Unable to open CDDA stream”

  • You must to post comments
0
0

Ok, here are the specs:
Pentium 2 266 mhz
128 MB RAM
Windows 98
Crystal Soundfusion AC97 Soundcard
ATI Rage Pro graphics card
DirectX 9.0
Matshita 32x CD-ROM

Yeah, I’ve used a few CDDA extraction programs, AudioCatalyst / Audiograbber (XING), and a few others in the past. They’ve all worked correctly and haven’t taken a lot of CPU time at all. Plus, I use Sonique 2 which also has CD ripping to do CDDA visuals and it works fine.

  • You must to post comments
0
0

[quote="andrew":20kohdg2]Paranoid Android, does the CPU usage jump like that when you put effects on an mp3 or only for CD tracks? The effects are definitely not taking that much CPU time so it may be that I’m calculating the CPU usage incorrectly. If you check out the Windows performance monitor you’ll see that FMOD’s not taking much CPU time at all.[/quote:20kohdg2]

Well, I just tested it with an MP3 and I observed the same problem, when the song was playing without any DSP effects the cpu usage was around 1%, but when I turned effects on and then turned them back off the CPU usage started growing rapidly, it started around 2% and kept going up and eventually stopped at around 24%. Which isnt as bad as when playing a cd track where the cpu usage reached up to 100%. SO, Im not sure what the problem is, but without any DSP effects, both MP3 and CDA work perfectly with CPU usage at 1% – 1.5%.

  • You must to post comments
0
0

Paranoid_Android and J-F, I’ve put up a special debug version of the media player so I can get some more detailed information from you guys. Please download this:

[url:3l1v29ha]http://www.fmod.org/files/fmod371_debug.zip[/url:3l1v29ha]

…go into the Options dialog, hit the “Device info” button and then email me the results. Also, let me know if the CPU usage is any different with this version and whether it skips more or less.

If anyone else has problems with skipping, it’d be great if you could get this debug version and do the same.

Thanks a lot guys, you’re being a great help!

  • You must to post comments
0
0

There’s an updated version of the media player at:

[url:3dplndc6]http://www.fmod.org/files/fmod371.zip[/url:3dplndc6]

A number of compatibility issues have been fixed and the error handling code has been improved so it should work across a much wider range of devices now.

Thanks to the people who’ve been downloading and testing! It really helps a lot. Keep the bug reports coming!

Cheers,

  • You must to post comments
0
0

Is there a way, like in the FMod Player, to have the jitter correction %? I searched in the CHM file and didn’t find any function to get it.

By the way, the CPU usage is now perfect, about 0.5 %, with jitter correction or not.

  • You must to post comments
0
0

First:

Sorry, I didn’t know that there was a config dialog box, now I know what is the system menu 😆 … In the config dialog, no CD drive was selected so no CD was loading. I selected one, the G:, and know it works

Second:

It’s about the CPU usage, it starts at 1% and go up until 45% and then it stays there.

  • You must to post comments
0
0

Andrew, my device report have been sent to you.

But there is a problem:
The first device, G: (DVD-Rom), works perfectly, but the second, H: (DVD±RW) isn’t recognized, I get the error message “ERROR: Couldn’t access CD/DVD device at H:” if I want a device report or if I want to load the CD.

Hopefully there is a good new, the CPU usage stays at about 7%, which is better but not necessarely exact.

Hope it will help!

  • You must to post comments
0
0

Cool the new one works sweet:)

  • You must to post comments
0
0

J-F, no that jitter correction % was just for beta testing.

Paranoid_Android, is the final release any better on the CPU time?

  • You must to post comments
0
0

Ok, there’s a new version available at :

[url:3mu6nypo]http://www.fmod.org/files/fmod371.zip[/url:3mu6nypo]

Changes :

  • Fixed CPU usage reporting
  • Fixed CD drive detection (thx J-F!)
  • Reworked interface to make Options dialog easier to find
  • Minor fixes

Enjoy!

  • You must to post comments
0
0

Ok, there’s a new version of the FMOD media player available at:

[url:38a0z9p9]http://www.fmod.org/files/fmod371_debug.zip[/url:38a0z9p9]

You can now turn jitter correction on/off in the Options dialog. If you’re getting very high CPU usage, try turning jitter correction off and see what happens. If this doesn’t help, hit “Device info…” in the Options dialog and send me all the results.

Also the “amount” of jitter that’s being corrected is now displayed as the CD plays. If this doesn’t stay on or close to 0% then let me know what it gets to and what your CPU usage is and also send me your device info.

Thanks everyone!

Oh, and btw, J-F you’ll only be able to access your first CD device if you’re using ASPI. Sucks, I know, but that’s how it’s going to be for FMOD 3.xx. FMOD 4 won’t have this limitation.

Cheers,

  • You must to post comments
Showing 1 - 20 of 42 results
Your Answer

Please first to submit.