0
0

Hello,

I have a problem when I’m trying to use the Microsoft CE-Emulator in Visual Studio2003. I get an exception, such as MissingMethodException. It doesn’t matter what method out of the dll I try to call. I checked the typing several times and compared it to the dumpbin-output, but without success. When I start my application in .NET FullFramework it works just fine. I also copied the dll to the folder with the exe-file, the windows-folder and all other folders that refered to .NET in any way. It is simply the same exception that is thrown as when the dll doesn’t exist in any way on the emulator.

This is very strange and I also used different fmodce.dll-files already.
Is there a limitation with this emulator?

Thanks for any help

  • You must to post comments
0
0

Hello brett,

thanks for your fast answer.

Yes, VisualStudio2003 allows developing in .net CompactFramework for CE-Platforms. I spent the whole weekend in finding out how to get the fmodce.dll work, but without success. No matter what method in fmodce.dll I try to call I always get a MissingMethodException. I am in real despair and don’t know how to adapt my wrapper to the compact framework :cry:. Is there anybody who already tried calling fmod in .NET CF?

Any help would be very welcome

Thanks a lot

  • You must to post comments
0
0

WWWWWWOOOOOOOOOWWWWWWW, I got it working! 😀
It was the wrong dll I was using. I concentrated on using the fmodce.dll’s in the emu-folders and therefore I got the MissingMethodException. But when I tried the dll in wce\x86-folder it suddenly started playing. Now I only have to manage the string passing to fmod. In another post I read about difficulties on how the string is interpreted. But this isn’t something I am really concerned of.

Two questions are left however:
1) What do the emu-folders in the api stand for when they don’t apply to the emulator?
2) Is there a chance to use the fx-functions in WinCE since there is no directSound-support (as I read somewhere)? Any help would be welcome.

Greets

  • You must to post comments
0
0

Just wondering if you got this resolved…. I am facing the same error.

Thanks.

[quote="eyeluminator":2j36h175]Hello,

I have a problem when I’m trying to use the Microsoft CE-Emulator in Visual Studio2003. I get an exception, such as MissingMethodException. It doesn’t matter what method out of the dll I try to call. I checked the typing several times and compared it to the dumpbin-output, but without success. When I start my application in .NET FullFramework it works just fine. I also copied the dll to the folder with the exe-file, the windows-folder and all other folders that refered to .NET in any way. It is simply the same exception that is thrown as when the dll doesn’t exist in any way on the emulator.

This is very strange and I also used different fmodce.dll-files already.
Is there a limitation with this emulator?

Thanks for any help[/quote:2j36h175]

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.