0
0

Hi,

How can i use the FMOD in a service application.
The problem is that the FSOUND_init throws an error ‘cannot set cooperative level for hardware’

If i use WINMM driver then the init is done, but i cannot use DSOUND.

If i build a normal application then the DSOUND is working.

But i want to try to build a small service, and there is no DSOUND available.

How can i overcome this ?

I am using Windows XP SP1 with Audigy 2 Sound card
but on other XP machines with other card i got the same results.

Sandor Dobi

  • You must to post comments
0
0

Normally a service runs in the background with no User I/O at all, so I don’t think the globabfocus would work.

The only suggestion I have at all would be to use WINMM output, short of that, due to the way a service works, I don’t think you will get FMOD to output at all.

  • You must to post comments
0
0

I don’t know if this will make a difference, but give this a try:

  1. Make sure the service is stopped (propbably the case if you are getting errors).
  2. Open the Properties dialog for the service.
  3. Switch to the ‘Log On’ tab.
  4. Enable the ‘allow service to interact with desktop’ checkbox.
  5. Click on the Apply button.
  6. Switch back to the ‘General’ tab.
  7. Click on the Start button.

Hope it works!

  • You must to post comments
0
0

Thanks

Right now it seems that only WinMM is working, i tried several tips to make work the DSOUND option but no result.

Thanks everone for the tips

Sandor Dobi

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.