Ok, I’m probably missing something extremely easy here, but I’ve tried whatever I could think of.

I’m using miniFMOD for my 64k intros, simply because I only need XM playback and it’s a requirement at this compo to only use 1 file ( thus linking in a .dll isn’t allowed ).

Anyway, my problem is when I try to strip away the standard libraries. Even though I link in the minifmod.lib ( everything works when linking with standard libraries ) I get unresolved external symbols to _FMUSIC_PlaySong, FreeSong etc.

Why? I’m still linking in the minifmod.lib ( or atleast I should be, since I didn’t touch that code ). Any help on this is appreciated.

[i:3u4pnd66]my guess is that minifmod in turn require the standard libraries, and thus won’t work if I disable the standard libraries[/i:3u4pnd66] – if that’s the case, is there any workaround? the standard libraries are huge :(

I’m using MSVC.net if that’s of any help.

Thanks in advance,

  • You must to post comments

Aaah. Thanks :)

Wasn’t that ( they were at multithreaded in my project ), but I just now noticed that I had recompiled minifmod using the wrong linker options :)

Thanks a bunch :) from 108 kB to 16 kB, and that’s including a 23 kB XM-song – not bad 😀

Time to get busy :)

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.