0
0

I’m trying to do a simple application in wich a mp3 file will be played, this is how im trying to do it:

void main()
{
FSOUND_STREAM *samp1 = NULL;

FSOUND_SetOutput(FSOUND_OUTPUT_DSOUND);
FSOUND_SetDriver(1);                 

FSOUND_SetMixer(FSOUND_MIXER_AUTODETECT);

FSOUND_Init(44100, 32, 0);

FSOUND_Stream_Open("../../media/war.mp3",FSOUND_STEREO,0,0);

FSOUND_Stream_PlayEx(FSOUND_FREE, samp1, NULL, false);

while (1);

}

but only one speaker is playing ( i have a 5.1 set ).If i use FSOUND_HW3D in stream_open there is no sound at all.

  • You must to post comments
0
0

HW2D doesnt works too, but there is a strange thing i forgot to mention, small file ( like the drumloop.wav) works, but if i go any bigger, lets say a 3 megs mp3, nothing works…

  • You must to post comments
0
0

my probleme is more weird then i first tought, let me explain, if i use Window Media player or anything else the sound is perfect ( 5 speaker playing) but I’ve notice that when my computer start /shutdown or if i test the window sound in the control panel only the front right speaker is playing…( that’s what happen with my fmod app) even the dsp sample( when you select hardware(3) the jules.mp3 is only playing on front right speaker)…

  • You must to post comments
0
0

I also have a problem where one speaker is playing sometimes and not others. Not sure whether it is to do with my hardware or FMOD. Will try to track it down when it next happens.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.