0
0

I have a mixed-mode CD with 2 audio tracks and one additional data track.
FSOUND_Stream_GetNumSubStreams() returns 1 and I have no chance to play the second track in digital mode.
Any ideas? :)

  • You must to post comments
0
0

Here’s a fixed dll :

[url:1cyaa4kk]http://www.fmod.org/files/fmod.dll[/url:1cyaa4kk]

Thanks for your help jus!

  • You must to post comments
0
0

Hello,

I’m running under linux mandrake 9.2, and i’m wondering how i can activate the digital mode for my dvd because i cant read any cd.
Is there a solution in the fmod library to activate the digital or analogical mode for device.

thx.

  • You must to post comments
0
0

You should be able to access the CD with the FSOUND_CD_* functions under linux. FMOD doesn’t support CD Digital Audio under linux.

Cheers,

  • You must to post comments
0
0

Can no one reproduce this problem? 😕
Even the MiniFMOD 1.7 has the same problem. Just activate “digital playback” and insert a mixed-mode (CD-Extra) CD. It seems that the data track confuses FMOD and the last track is missing.

Thanks for your help.

Jürgen

  • You must to post comments
0
0

Hello,

In fact, when i use the FSOUND_CD_* functions, it works ( i mean my cd turns and i use FSOUND_CD_Eject, it ejects the cd), the trouble is that i don’t hear anything. I use my program on a another computer which has a audio cable, and it works perfecly.

I think there’s no solution to my problem :(
thanks for your answer, this library is amazing !!! I am very surprised how it’s easy to use.

punx120[/i]

  • You must to post comments
0
0

ok, but I have the same problem in my application, so it seems to be a bug in FMOD. Any chance it will be fixed in a future release?

Thanks.
Jürgen

  • You must to post comments
0
0

[quote:1bvl5spv]I think there’s no solution to my problem [/quote:1bvl5spv]

Connect the audio cable from your cd drive to your sound card. Problem solved.

  • You must to post comments
0
0

Haven’t been able to reproduce it yet. Can you give me more information on the layout of the tracks/sessions etc.? What did you use to burn the CD and what options did you use for burning? Have you tried ripping the audio tracks using something like CDEX? Does it work or exhibit the same behaviour FMOD is showing?

  • You must to post comments
0
0

In Main.c of FMOD code

find this:
char setting_cdletter[4] = “C:”;

It could be that this fellow has multiple CD drives
e.g; DVD writer / CD writter combo and a CD player

To play CD’s and if the DVD / CD writter is listed first it will simply not
play the CD if the CD is in the second CDROM drive.

Just a thought!

Euman

  • You must to post comments
0
0

Thanks for your reply, andrew.

This is an orginal CD and it works perfectly in CDEX. I have attached 2 screenshots.

[img:2la5ucz4]http://www.hitbase.de/cdex.jpg[/img:2la5ucz4]
[img:2la5ucz4]http://www.hitbase.de/fmod.jpg[/img:2la5ucz4]

Thanks for your help.

Jürgen

  • You must to post comments
0
0

Fixed. Get the latest dll at :

[url:3108hmeq]http://www.fmod.org/files/fmod.dll[/url:3108hmeq]

Thanks jus!

  • You must to post comments
0
0

Andrew,

thank you very much for the new version. The second track is now detected and can be played. 😀

However, I have still a problem with the track length of the second track. I have attached a new image (same CD as before):

[img:23nj40gl]http://www.hitbase.de/fmod2.jpg[/img:23nj40gl]

CDEx detectes the correct length of 4:26. FMOD returns 6:26.

Thanks again.
Jus

  • You must to post comments
0
0

Ok, I’ve made another fix – could you do me a favour and download and run this test program :

[url:1mzdqhnz]http://www.fmod.org/files/cddatest.zip[/url:1mzdqhnz] (it’s only 156kb)

Make sure the problem CD is in the drive when you run it. Could you also capture [b:1mzdqhnz]all[/b:1mzdqhnz] the output and email it to me at andrew@fmod.org.

Thanks a lot jus!

  • You must to post comments
0
0

Andrew,

I have sent you the results via e-mail. It seems to work now! 😀

Thanks!
Jus

  • You must to post comments
Showing 14 results
Your Answer

Please first to submit.