0
0

Hello,

I have build a small player to play MP3’s.
When I run it without any intenset background activities everything runs very well, but when I for example open a DOS bos and start some CPU taking activity (UPX for example) the sound “hacks”.

I have set HWND, I use DirectSound together with FSOUND_INIT_GLOBALFOCUS or FSOUND_INIT_ENABLEOUTPUTFX and I have a buffer of 200ms.

Any hints how I can avoid these “hacks” ?

Thanks in advance

  • You must to post comments
0
0

There are other buffers you can set

FSOUND_SetBufferSize 100
this must be called before you init FMOD

The larger the buffersize the more time it takes to respond
to stream changes (stopping, volume, panning ect…)

This might help

  • You must to post comments
0
0

Thanks for the answers both of you.
I had set the buffer with FSOUND_SetBufferSize to 100, but have now made this setting user controlled, so if anyone needs more they can set it.

Cannot afford loosing the spectrum, so I will keep running it via a SW mixer.

Thanks again!

  • You must to post comments
0
0

Look also that if you have Win9x kernel, you’ll get this kind of problems when using waveout and smaller buffer sizes (<250 ms). You may try using DSound.
With NT kernels, you should be able to set buffer around 100 ms and hear no hacks in most situation, even intensive use of CPU and even with waveout driver.

  • You must to post comments
0
0

I’m running WinXP Pro, using DSound and a buffer of 100ms.
This seems be to small on my machine at work, but OK at home.
(Same machine speeds, but different type of soundcards.)

Can the performance also depend on the soundcard?

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.