0
0

Hi all.

I’m using FSOUND_Stream_OpenFile() to get some background music. It’s playing alright, but at twice the speed, so I get this Mickey Mouse effect (or for the older people, the 45rpm vs 33rpm effect 😉 ).
Should the frequency of the music match my audio output frequency, or is this handled in FMOD’s wav/mp3 playing routines?

Thanks.

  • You must to post comments
0
0

Thanks, I’ll try that tonight.

  • You must to post comments
0
0

Mentos>your game is excellent, i recommend it for games cars fan !! Thanx for this to do it for free and don’t forget to keep up the good work :smile:

  • You must to post comments
0
0

Thanks! :smile:

I tried setting the frequency yesterday; I open the audio system with a 22kHz frequency, and the music is 44.1kHz; it seems it won’t be resampled automatically into the 22kHz output line, but a SetFrequency(channel,22050) did the trick.
Thanks for the info.

  • You must to post comments
0
0

That was Linux.
I already wondered; you seemed to imply that my FSOUND_SetFrequency() call was extraneous, but it wasn’t, even with WAV files (which surely have a correct header most of the time; in this case it was generated on an SGI using ‘mediaconvert’).
So no automatic resampling takes place.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.