0
0

I have noticed a brief delay between the time FSOUND_SetPaused is called on a playing stream and the time when the music actually pauses . Is there a means to immediately pause a stream?

I’m using fmod 3.71 on Linux with OSS.

Thanks,

James

  • You must to post comments
0
0

Thanks for the quick reply. I had tried changing the buffer size and had not noticed any difference. I don’t think there is any inherent hardware issue as other OSS based players (e.g, XMMS with the OSS driver selected) are able to pause with no delay. However, I can’t offer anything beyond anecdotal evidence for this.

Incidentally, I have also tried using FSOUND_DSP_SetActive to disable various DSP units in the DSP chain, which does pause the music, but there is still a delay.

I will try using ALSA to see if this makes a difference. Thanks again for the reply.

-James

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.