0
0

Hi all,
First sorry for this question that could be more Xcode related than fmod, but may be someoune else run into this problem and hopefully solved it.

I am using fmod on mac osx, and it works fine, it can play, record, dsp and all that nice stuff.

Unfortunately I am having a problem when compiling my source with the “Zero link” xcode feature turned on (that speeds up a lot compile cycle, so it is handy on my slow mac). I have a complaint from the linker saying

“ZeroLink: unknown symbol ‘_FSOUND_GetVersion’

ToyTheatreLab2.0 has exited due to signal 6 (SIGABRT).”

_FSOUND_GetVersion is the first function that should be used from libfmod.a

Turning off zerolink ends to a successful (but slow…) compile and link with no errors.

I tried hard to solve this myself, but at the end I gave up. So any help will be very much appreciated.

Thank you
davide

PS this applies to the code I posted a while ago, if anyone would be willing to check

  • You must to post comments
0
0

i’ve got the same problem here after i upgrade my target project to the nativ. But if you compile the application without Zero Linking everything works fine.

Sven

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.