During the last few months, I have never been able to get fmod working with ALSA output under linux. Even the samples that come with the fmod distribution don’t work. The FSOUND_Init call gives a segmentation fault (when I have the output set to ALSA), and that’s it.

This is the output of the “simple” sample: (I have added a few printf’s to check which line causes the segmentation fault)

stijn@darkstar simple $ ./simple

Output Type

1 – OSS – Open Sound System
2 – ESD – Elightment Sound Daemon
3 – ALSA 0.9 – Advanced Linux Sound Architecture

4 – NoSound

Press a corresponding number or ESC to quit
3Output type set!———————————————————

ALSA Driver list

1 – Intel 82801DB-ICH4

2 – Sound Blaster Live!

Press a corresponding number or ESC to quit
1Driver set!
Trying to initialize!
Segmentation fault
It doesn’t matter which sound card I select.

However, it has worked for me a long time ago, when I was using an older version of ALSA. (I guess ALSA 0.96 worked, but every ALSA version later than that didn’t). I am now running a 2.6 kernel which has ALSA drivers built-in into the kernel (I have used kernels 2.6.0 up to 2.6.5) , but I remember that, when using a 2.4 kernel and separate alsa drivers, it didn’t work, too.

Could this be an incompatibility between fmod and the newer ALSA drivers?
Using OSS output (using ALSA OSS emulation) works, but it would be nice to have working ALSA support because ALSA allows multiple applications to use the sound card at the same time (using DMIX).
Other ALSA programs are working fine, like alsaplayer and xmms with the ALSA output plugin.

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.