0
0

Hi,

Im having a problem with two different FMOD dlls,

When I play any 3D sounds using the 3.7.2.0 FMOD.dll, the sounds appear to be all ‘speeded’ up. But when using version 3.7.1.0 they seem to play fine? Do I have to get a new header file fmod.h for the newer vesion?

On an off-topic, when I play 3d sounds, sometimes the whole sound doesn’t get played, has anyone else experienced this? I don’t think it’s my code, (although I could be wrong)! 😉

Cheers,

B.

  • You must to post comments
0
0

Brett,

I am experiencing the exact same problem as ShrineBot, but it’s only on some computers. I don’t even call any of the functions you mentioned at all, and yet the sound is speeded up on one particular machine (Asus, AMD Athlon 2600Mhz). The sound card is the one on the motherboard, I don’t know the model # but I should be able to get it.

Out of curiosity I used GetDefaults to get the frequency and the sample is using the exact same frequency (22050) on both computers. I even tried explicitly setting the frequency on the channel to that same value before it plays but it didn’t make any difference.

Also, upon further experimentation, the FSOUND_SetFrequency has NO effect whatsoever on the sound on the problem computer, but works perfectly on my other machines.

This bug does not exist with version 3.7.1.

Any ideas???

–Paul

  • You must to post comments
0
0

Does that explain why 3.7.1 works and 3.7.2 doesn’t?

  • You must to post comments
0
0

I understand what you are saying, I guess I should have phrased my question differently (btw, if I remove FSOUND_HW3D it plays correctly, so you are probably correct as to the cause). Did 3.7.1 just disable HW3D automatically if the card didn’t support the sound’s frequency rather than clamp between the supported frequencies?

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.