0
0

I would like to know if there’s a way to stream a CD-Audio track like the “fmod media player” does (loading CD tracks)… and how can I do it (an examples would be nice).

The Delphi example does not stream cd-audio. It plays directly from those CD controls.
The reason is because the fmod media player plays a CD-Audio without making the CD spin very fast, thus not producing a lot of noise from the CD drive.
I think that “Sly” is the one who updates the Delphi port ? Please help.

Also “FMOD Media Player v3.72” has a bug that it keeps jumping from one CD track to another instead of playing it (v3.71 works fine).

Thanks in advance.

  • You must to post comments
0
0

cool!! 😀
I’m looking forward for the next update.

  • You must to post comments
0
0

are you sure this is not a bug related to your pc setup as the testbed works perfectly on my pc, are you sure you have updated your fmod.dll and that you are using the new api pas files not the old ones (eg check the directory in delphi’s environment settings)?

  • You must to post comments
0
0

“testbed” (Delphi) app works fine, but it does not do CD-audio streaming, only audio files like .mp3; .wav; .wma etc…
I’m looking for a way to detect the total CD-Audio tracks, put them into a list and play them, one by one (by using streaming commands not the standard CD-Audio commands).

I’m talking about the “FMOD Media Player” that is available for download. There’s no source code with it. I tested twice, v3.71 and v3.72
Again, v3.71 works fine and v3.72 does not work correctly.

And yes, I’m using the correct fmod.dll file for each version of the FMOD Media Player.

Thanks for helping :)

  • You must to post comments
0
0

ok, it doesn’t work for me either, i’m not sure that the program does anything different to the testbed though, i think it just allows you to add cd tracks to the playlist and plays them in the same way as the testbed does

  • You must to post comments
0
0

No it does not work the same.
With “testbed” the CD spins in max speed in the cd-drive, making a lot of noise (Media Player 9 does the same), and it does not use streaming to play CD-audio tracks, it uses those specific CD-Audio commands from FMOD

The “FMOD Media Player” plays CD-audio in streaming mode and the CD spins very slow, like the CD-Player does in Win9x systems. This is much better since the cd-drive does not make too much noise when playing CD-Audio.

but I might be talking BS and be completely wrong about this.
I’ll stick with FMOD Media Player v3.71 until this is fixed in the latest version.

  • You must to post comments
0
0

i just had a look at the fmod.dll functions the media player uses and it does use the fsound_cd functions, using the testbed on my pc doesn’t use the drive at full speed

  • You must to post comments
0
0

that’s weird.
Maybe I’m just unlucky :(
I have a LG DVD-ROM 16x drive.

  • You must to post comments
0
0

I managed to use play a CD in stream mode, but FMOD have a two seconds pause between two tracks, even if the next track does not have a 2 seconds pause.

I mean, it takes two seconds to close the current cd track and start playing the next one.
Is there a way to make the FMOD play without that pause between tracks ?

  • You must to post comments
0
0

Most CD burning programs will put a two second gap between audio tracks by default – this is probably what you’re experiencing. FMOD just plays what’s on the disk – if there’s two seconds of silence on the disk it’ll play two seconds of silence. Look in the settings for your CD burning prog – most of them will let you burn without the gap.

  • You must to post comments
0
0

yes I know that. :)
I mean, FMOD is adding an extra 2 seconds between track.

I have a CD here that plays two tracks without the 2 seconds pause (a long music separated into two tracks in the CD).
When it reaches the end of the current track, instead of a continues playback, FMOD pauses the music for two seconds, when the CD does not have this pause.

Anyway, thanks for replying :)

  • You must to post comments
0
0

Ok, I’ve made a fix for the 2 second gap problem. It’ll be available in our next incremental release which will be out very soon.

Cheers,

  • You must to post comments
Showing 11 results
Your Answer

Please first to submit.