0
0

It works well with soundcard supported Hardware Accellation..

To supported non hardware accellated sound card
I tested like this ..
FSOUND_SetMinHardwareChannels( 256 ); // my soundcard’s hardware buffer is 32…
then FMOD would run in software mode..

Problem is 2D sound sample played 3D sound like..
( I think.. it is Panning.. sounds awfull )

p.s : 2D sound sample loaded with flag ( FSOUND_NORMAL | FSOUND_2D )

  • You must to post comments
0
0

my problem is 2d sound works like 3d sound in software mode

beside I didn’t test in soundcard with non-surpported 3d accellation..
I’m afraid that It would be sounds like this…

and if it can be done with FOUND_Init
Could you tell me more specifically?

  • You must to post comments
0
0

everytime playing sounds.. set loop or not..

if(bLoop)
FSOUND_Sample_SetMode( pFS, FSOUND_LOOP_NORMAL );
else
FSOUND_Sample_SetMode( pFS, FSOUND_LOOP_OFF );

then

r = FSOUND_PlaySoundEx( FSOUND_FREE, pFS, 0, true );
if(b3d)
FSOUND_3D_SetAttributes( r, (const float)pos, (const float)vel );
FSOUND_SetPriority( r, priority );
FSOUND_SetVolume( r, vol );
FSOUND_SetPaused( r, false );

maybe inital setting has problem..

FSOUND_SetMinHardwareChannels( 256 ); //to run software mode
FSOUND_Init(maxrate, 16, 0 );

and following code is loading wave file…

FSOUND_SAMPLE* r = FSOUND_Sample_Load(FSOUND_FREE, Buffer, (FSOUND_NORMAL | FSOUND_2D | FSOUND_LOADMEMORY), 0, SoundFileLength)

at win2k, Avance AC97 Audio, Radeon 9600 pro

  • You must to post comments
0
0

I did.. foolish mistake..:(
thanks for reply…

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.