0
0

Has anyone successfully got fmod to compile under mac os x with Xcode. I can not for the life of me figure out how to do it. It does compile but… It gives this error and doesn’t do anything.

ZeroLink: unknown symbol ‘_FSOUND_GetVersion’

simplest Final has exited due to signal 6 (SIGABRT).

How would I fix this. Please give a detailed explanation on how you got it to compile with Xcode.

Your help is greatly appreciated. Thank you.

  • You must to post comments
0
0

I opened the .mcp file. Here is what I have.

Source:

Carbon.r
Main.c

Libraries:

MSL_All_Carbon.Lib
CarbonLib
fmod_cfm.lib

Link Order:

Carbon.r
MSL_All_Carbon.Lib
CarbonLib
main.c
fmod_cfm.lib

That all compiles fine. It works perfectly with Metroworks CodeWarrior 8.0.

However, when I get the exact same files and set it up exactly like it was in CW, It still gives me the error i said before when I try to compile in xcode. You said I need to link to libfmod.a. But it works without it in CW… and I have allready tried linking to libfmod.a and still compiles with the same error. Thanks.

  • You must to post comments
0
0

Okay, I now know that Xcode uses Zerolink which speeds up the compile time. However, I have no idea how to turn it off. I have looked on the internet for a while and people just say turn of zerolink to fix the problem… Anyways, even in Codewarrior 8.0 “simplest” compiles and says “file not found”. I don’t know what it is talking about because the paths to all files are correct… Any ideas?

  • You must to post comments
0
0

FMOD works (quite) fine with xcode, of course since it uses gcc you have to link libfmod.a and carbon framework if you don’t have it already.

Unfortunately you have to turn off zerolink if you want your program to start, since there are problems runtime linking a static library.
This can be done selecting your project at the left (first icon at the top, the blue one) then selecting Project->Get info ->Style tab and deselecting zerolink.

This makes your compile time much longer, however, if your code is not the shortest.

A workaround for this would be very much appreciated!

Hope it helps,
Davide

  • You must to post comments
0
0

hi again,
Sorry for this noobish question ๐Ÿ˜ณ but i’m moving over from CW to Xcode and… Anyways, how would you go about linking libmod.a and the Carbon framework in Xcode? Thanks!

  • You must to post comments
0
0

I have not xcode here at the moment, but should be something like this:
open the project node (the top, blue one at the left) and look for the “External frameworks” folder (if it is not there, create it).
The right click (ctrl-click if you have a one button mouse ๐Ÿ˜• ) and select add framework… then find out carbon and fmod.

Should work, to add libfmod.a I’m not sure since I’m using Qt ( very nice and free) that builds the .xcode project for me and includes that.

Ciao
Davide

  • You must to post comments
0
0

I’m Screwed…… Same error as before even after I followed your dirrections to the letter… Heres error: ๐Ÿ˜ฎ

ZeroLink: unknown symbol ‘_FSOUND_GetVersion’

Simplest has exited due to signal 6 (SIGABRT).

Anymore ideas? could someone e-mail me their xcode project files along with the files it needs? Please!!! Tell me if you can and i will give you me e-mail. Thank you!

  • You must to post comments
0
0

If you want to install Qt library (that would be a good idea :) ) you can have a look at http://web.rossoalice.it/davidemania and download my little example.
It is not perfect but should compile under xcode.

Sorry but I’m on a hurry (must go to work), let me know if it works

ciao
Davide

  • You must to post comments
0
0

I am working on getting FMod to compile under XCode. I haven’t figured it all out yet, but I have figured out how to turn off ZeroLink:

  • Find your Project window
  • Right click on the target (generally the outermost item in the tree-view on the left). For those of you with one-button mouses, I believe this is Option-click.
  • Choose “Get Info” from the popup menu. You should get a dialog called Project “projectname” Info, and it will have four tabs: General, Code Sense, Styles, and Comments
  • Choose “Styles.”
  • Scroll down until you find the checkbox called “Zero Link.” Uncheck it.

Unfortunately, XCode does not intelligently detect that you have changed settings and rebuild your project. You have to choose “Clean” or “Clean All Targets” from the Build menu, and then start your build over again. Once you’ve done that, you should compile and link in the more conventional way.

  • You must to post comments
Showing 8 results
Your Answer

Please first to submit.