0
0

First off, I’d like to say that the library is excellent and was very easy to incorporate into my existing projects!

Now, enough of the flattery– here’s my issue :smile:

Is there a known problem with the CE version of fmod where it does not properly shut down the Windows MM system when the FSOUND_Close() routine is called?

I’ve been able to get the system to work flawlessly, but everytime my game exits, the sound system is somehow still “locked” and NO other program can play sounds until I perform a hard reset of the device (compaq 3635)!

I am only using FSOUND_Sample_Load and FSOUND_PlaySound for simple WAV files, and did not have the issue until I started calling FSOUND_Sample_SetLoopMode to make some of the wav files loop (at least, that’s when I started to notice the problem anyway).

I also switched from UNMANAGED sounds to “normal” sounds, but that did not solve the problem. I use the standard SetMixer and Init that I see in all the samples.

Have you seen this issue before? Is there a “proper” way to perform the shutdown? I do not ensure that all samples have stopped, do I need to?

Any help would be appreciated. Thanks in advance!

Gene Ostrowski

  • You must to post comments
0
0

Hi,

I am also having this problem. I play my game a couple of times and the sound is fine but then when I go in say the 3rd or 4th time there is no sound and I have to soft reset my device.

Any ideas?

Thanks in advance
Bad

  • You must to post comments
0
0

I have just had a look at the simple.cpp and see calls to FSOUND_Sample_Free for each of the samples. I have not got my laptop with me to try but I have a feeling this may be the problem as I am not calling FSOUND_Sample_Free.

Am I correct?

Thanks in advance
Bad

  • You must to post comments
0
0

Hi,

Thats strange, I havent had this problem. I just call FSOUND_Close() and make sure everything is freed. But theoretically all you need to do is call FSOUND_Close(), even if you dont free everything sound in other programs should work (although obviously it is terrible programming not to free everything especially on a handheld).

Are you sure FSOUND_Close() is always being called?

One interesting thing I found is that FMOD seems to respond to the system master volume setting automatically, but if the user unticks ‘programs’ in ‘enable sounds for’ then you have to detect that yourself.

  • You must to post comments
0
0

Update: I cant get it to do this if I try. Even if I exit on purpose without calling FSOUND_Close() it shuts itself down, presumably when the dll is unloaded.

  • You must to post comments
0
0

Simon,

Thank you for investigating this for me. I’m sure I call FSOUND_Close. I will step through my code later today.

Thanks again
Bad

  • You must to post comments
0
0

Hi,

FSOUND_Sample_Free() has solved my problem. Sound seems to work everytime now without the need of a soft reset.

Cheers
Bad

  • You must to post comments
0
0

I’ll give FSOUND_Sample_Free() a try in my code and see if it helps.

Thanks.

  • You must to post comments
Showing 7 results
Your Answer

Please first to submit.