0
0

I open one stream with only the FSOUND_IGNORETAGS flag and start playing that stream.

I then open another stream of the same file with the following flags, FSOUND_NONBLOCKING|FSOUND_MPEGACCURATE|FSOUND_IGNORETAGS, and use a timer to tell when it is open.

But now on one of my friends computers the sound gets very choppy while the first stream is playing and the second stream is loading, but seems to work fine on every other computer I have tried the player on?

The friends computer is a PIII 650 with SB Live and all the newest drivers and is running Win XP SP1.

PS. will using FSOUND_IGNORETAGS make the files open quicker?

  • You must to post comments
0
0

maybe you try before opening your engine with FSOUND_Init() to increase the Buffer size with FSOUND_SetBufferSize(100); or more… that solved the problems i had…

  • You must to post comments
0
0

I have tried both of these suggestions with no luck. It is not that the whole song is clicking or playing

choppy, but only at the beginning of the song when I am loading another stream in the background with the

FSOUND_NONBLOCKING flag. If I do not load a stream in the background it works fine.

Here is a small mp3 (111KB), so that you can hear what the start of any song sounds like:

http://www.geocities.com/beans_programs/SmoothBug.mp3

Thanks.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.