0
0

I’m trying to get FMOD running with Ogre. It’s all working nice and fine ๐Ÿ˜‰ except the fact sounds and everything drops of VERY fast in 3D. I thought I would correct that with the aforementioned command.

Now, whatever setting I give to it it won’t do a thing. Setting

FSOUND_3D_SetDistanceFactor(10000);
or
FSOUND_3D_SetDistanceFactor(0.00001f);

won’t make any difference. I know the numbers are crazy a bit, but I was pushing them up when I couldn’t hear the difference… and even with those I still can’t.

I wonder what could I be doing wrong with them though.

This is where it is used:

[code:f95t121x]
void initSoundSystem(int khz, int channels, int vcm, int buffsize)
{
if (!FSOUND_Init(khz, channels, vcm))
{
Except(Exception::ERR_INTERNAL_ERROR, "Failed to initialize sound!", "GEMSound::initsound");
exit(1);
}
if (buffsize != 0) FSOUND_SetBufferSize(buffsize);
FSOUND_3D_SetDistanceFactor(10000);
blah balh usual stuff below
[/code:f95t121x]

I thought it would be enough to call it once, after initializing. Should I call it before every update too or something? :S

  • You must to post comments
0
0

Sorry, I misunderstood it. My bad. I thought setting a different scale would solve everything… say, am I naive or something? lol
I set SetRolloffFactor and now it works as supposed to. Kudos, you spared me lots of hair and painsticking ๐Ÿ˜€

Btw – ogre is a graphical engine :) http://www.ogre3d.org

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.