• Cameron Baron

    Are you able to attach the output logs for a build when this happens? Using the logging libs if possible.

  • Benjamin

    This problem is happening in the editor.

    Here is the most recent log we have. Sorry if it doesn’t help. I’m not familiar with all this log stuff yet.

    https://www.dropbox.com/s/0esw3c1emqu9kp8/2017-08-25-17-02-39_log.txt?dl=0

  • Cameron Baron

    Sorry I was meaning the logs from Unity.

  • Benjamin

    https://www.dropbox.com/s/wd5aiqkphnnhc3a/Editor-prev.log?dl=0

    Hope this helps.

    I’ve double-checked this issue again. To clarify a bit more, the sound sources themselves don’t stop playing, just the room effect. With GVR, even beyond a sound’s maximum distance it will still be present in the audioroom reverb effect. When the player, however, is outside a sound source’s max distance and looks away from the sound sources in my scene (up, down, or just in the opposite direction), the reverb stops playing entirely.

  • Cameron Baron

    The first thing I can see from the logs is that there is no FMOD Studio Listener in the scene, usually this is attached to the Camera/Player depending on your game.
    Also your event AirPump_Short_Release2 should not be audible as it is not getting it’s position set using set3DAttributes().

    I will look into the GVR and room reverb a bit more.

  • Benjamin

    Yea this listener issue seems to be a bug from using VRTK. There is most definitely a listener on the player but that error consistently pops up.

    The AirPump audio issue has also been another confusing item although it doesn’t seem to be causing any harm in the end. That event is not used anywhere in the project but throws errors all the time and if I delete the event from the FMOD project the PhysSound engine stops working entirely. Have no idea what’s going on there…

  • Cameron Baron

    In the Unity console window it will show these warnings, as well as the callstack, which will tell you exactly what scripts are causing them.

  • Benjamin

    Any progress on this issue? I haven’t had any luck getting it to go away.

  • Cameron Baron

    Can you share the log file/s that show the errors you have mentioned?

  • Benjamin

    If it didn’t pop up as an error in the last logs I sent then I don’t know what would change if I send them again. Sorry, I’m not very familiar with this level of troubleshooting. I’m not getting any errors when this problem occurs, it just happens.

  • Cameron Baron

    Sorry the fact that the post with the file was removed threw me off.
    What version of FMOD are you using?

  • Benjamin

    1.09.08. I just saw that there has been an update, although, with my project mostly finished except for this issue, I’m hesitant to upgrade at this stage.

  • Cameron Baron

    If you are almost finished and don’t urgently need the features then I wouldn’t update to a new major version.

    I’m unable to reproduce the issue you are seeing.
    Recording a Studio Profiler session may be able to shed some more light what is happening. Feel free to send a copy of the Profiler session or game to support@fmod.com and we can see what we can find.