Answered
0
0

Hi,
I have until now used older version of fmod, where I often used sequential playback of a multi instrument. Until now it was easy for me to implement by just un-checking the random dice icon in the upper corner of the multi instrument.

If I do this now with a multi instrument containing a playlist of audio files it keeps playing the first file, when I audition the sound. It only skips to the next file in the playlist if I add a loop region again the multi file.

This is also the case when I test the game.

Has something been changed in regards to this in the newest version of fmod or am I doing something wrong?

Hoping to find some help on this, hopefully super easy question.

  • You must to post comments
Best Answer
1
0

The old behavior, where the most recently selected entry in a sequential playlist was tracked globally instead of on a per event instance basis, was a longstanding bug. This bug was fixed in FMOD Studio version 1.10.00; sequential playlists now track their most recently selected entries on a per-event basis.

The intended function of sequential playlists is to allow the creation of events that reliably play audio files in a predictable sequences. The old behavior did not fulfill that purpose, as which entry of a sequential playlist would play next always depended on the current and past state of every other instance of the event containing the instrument in the ongoing game or studio session.

Making the selection behavior of sequential playlists specific to the event instance allows sequential playback to function as intended.

  • You must to post comments
0
0

Hi Joseph,
Thanks for the answer.
This unfortunately still doesn’t solve the problem we have, which was very simple to do in the older version.
I have solved it now in a different, but more less simple way.

What would you think was the smartest way to play a sequential playlist if you could not have a looping sound?
We want to simple play a new file from a playlist in sequential order every time a button is pressed. It is super important that it is not looping.

And a small side question. If you want some files in a multi instrument to play to the end, that are longer then the multi instrument instrument element, is there a smart way to do that? In this case it is because I have some instruments that should be timed to start at the same time, but some of them have a reverb tale, that should be played to the end.

Niels

  • Joseph Harvey

    If you want to play a different audio file from a sequential multi instrument’s playlist each time the event is triggered, one simple way is to hold onto the event instance and reuse it for subsequent button presses, rather than releasing it.

    After some internal discussion, we have decided to add global sequential playback as an optional instrument setting in a future release of FMOD Studio. We have not yet scheduled this feature for development, however, and so cannot provide an ETA for its release.

    If you want a file in a multi instrument to play to end when the length of that file is greater than the multi instrument, all you have to do is ensure the instrument’s “cut playback when untriggered” button is toggled off. (This button is labelled ‘Cut’ and is located in the deck when the instrument is selected in the editor. You want it to be gray.)

  • You must to post comments
0
0

Hi Joseph,
Thanks a lot for the answers … that helped me a lot :)

Looking forward to this feature. I think that could be a nice simple feature, usable for many things.

Best,
Niels

  • You must to post comments
0
0

Hi Joseph,
I have been looking after the “cut” button in the dock when having selected the multi instrument, and I can’t find it. Sorry if Im completely slow or something.
I can only see volume, pitch, Async, the dice toggle, the loop button, add instrument, clear and then the volume and pitch parameters. I really can find the “cut” button.
I am using Fmod studio version 1.10.01, 64bit

  • Joseph Harvey

    Sorry, I should have mentioned that the cut button only appears if the instrument is set to Async mode.

  • You must to post comments
0
0

Hi Joseph,
And thank you for the answer.
I am still not completely sure how to set up the sequential playback then? Should It be working in game if I make a playlist in a multi instrument or did I misunderstand that?

The game I am working on is re-triggering the event and still just playing the first file in the multi instrument.

  • Joseph Harvey

    @NeilsBöttcher If you want to play more than the first entry in a sequential playlist, you must ensure the instrument plays more than one audio file in a single instance of the event. YOu can do this by setting the instrument to loop or by triggering it repeatedly. This is because each new instance of the event starts the playlist from its first entry, as I described.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.