0
0

Hi all,
I’ve update to FMOD 1.10.01 and now our PS4 builds doesn’t work anymore. Don’t know if i forgot to do something, cause I’ve read in another question that the error I got is related to a missing platform plugin, so I’ll tell you what I have done:

  • Update FMOD Studio to 1.10.01.
  • Copied the “libatrac9.dll” from the folder of the previous FMOD version.
  • Builded a new Bank.

  • Added the “Windows/Mac/Linux/Mobile” package for Unity.

  • Added the “PlayStation4” package for Unity.
  • Imported the new bank in Unity.

Now when I build I get the following error:
“Unable to resolve pinvoke method ‘FMOD.Memory:FMOD5_Memory_GetStats (int&,int&,bool)’ Re-run with MONO_LOG_LEVEL=debug for more information.”

I’m working with Unity 5.5.4p5.

Any clues of what is that error about and how can i solve it? On desktop everything is working fine and before the update it was working fine also on PS4.

Thank you for your help,
Simone

  • Cameron Baron

    Can you confirm the PS4 libs are enabled for the platform, select the lib and make sure that PS4 is checked in the inspector. Otherwise this setting can also be found in the metafile.

    Also the PS4 SDK was updated in 1.10.01 to SDK 5.000.

  • Simone Pellegrini

    I’ve checked all the libs imported with the PS4 unitypackage and they all have the PS4 checked to true.

    Regarding the PS4 SDK: You mean that from the 1.10.01 FMOD requires the SDK 5.000? Cause this could be a problem for us. We are close to the release and we can’t update Unity to a version that supports the SDK 5.000.

    Thanks in advance for you help,
    Simone

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.