We are in the process of updating unity to 5.5, but we have an issue with FMOD. When trying to play sounds on Android (gradle build) fmod causes the application to hang for 1-2 seconds.

On unity 5.4, we did not encounter this kind of a behaviour.

FMOD 1.07.06
Unity 5.5
Gradle build

It is easily reproducable if we try to play 4 or more sounds simultaneously.

  • Jeremias Kuitunen

    It happens every time. Yes the version should be correct (its not the v2 integration). FMOD.VERSION.number output on Unity Editor is: 67334. We do not have any issues on iOS though.

  • Cameron Baron

    Unfortunately we don’t maintain the old plugin anymore, and there have been a large number of fixes between then and now. Have you thought about/tried using the new plugin?
    There are a few steps to migrate over but we do have a tool to help with that:

  • Jeremias Kuitunen

    Yes we are looking into updating the plugin at the moment. I’ll post the results here. Hopefully that will fix the issue.

  • Jeremias Kuitunen

    Updating to the newest FMOD fixed the issue, but it created another one: Sound playback is delayed (lag?) by 1-2 seconds :/. Is there some settings that should help with this?

    I tried setting different buffer values in RuntimeManager before studioSystem.initialize. We did not see any noticeable difference.

    //like this
    lowlevelSystem.setDSPBufferSize(1024, 4);

  • Cameron Baron

    Are you loading sample data before playing the events?
    This can add a delay to the sounds as it will have to load the data when play is called. In the FMOD Settings in Unity, you can choose to load all sample data or you can load each banks sample data individually.

Best Answer

Thanks for the support! Updating to the newest FMOD (Version 1.09.03) fixed the freezing. Ticking “Load All Sample Data at Initialization” fixed the delay with playing sounds on Android.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.