0
0

Hi to all,

I need some help to build my first game with Unity FMOD to iOS.
I’ve exported my project in unity and opened it with Xcode, after, i’ve started building but i’ve got an lot of “Match-O Linker” error (201 errors).
I haven’t done any modification to the standard Xcode project exported by unity and I don’t have any plugin in my unity project connected to FMOD.
The documentation is very poor and I can’t find any guide on how to set up iOS build with Unity FMOD.

here a screenshot of Xcode: https://1drv.ms/f/s!AugIyl84F-ffj_E2SktZpxwDhPKeHw

Anyone can help me?

Thanks

  • Cameron Baron

    Are you able to provide a log file with the errors?

  • Simone Dosi

    Hi Cameron,
    I’ve attached to my post a OneDrive link with 3 screenshots.
    Thanks!

  • You must to post comments
1
0

You will need to disable the inbuilt Unity audio, steps can be found here:
https://fmod.com/resources/documentation-api?page=content/generated/engine_new_unity/troubleshooting.html#/

  • Simone Dosi

    I can’t disable the Unity Audio!
    I use it for a “voice-over” at runtime… how can i solve this?

  • You must to post comments
0
0

Can you confirm the libs are being copied over to the Xcode project.
They should be under: ProjectName/Libraries/Plugins/iOS/
The main one you need to look for is “libfmodstudiounityplugin.a”

What version of FMOD Studio and the FMOD Unity Integration are you using?

  • Simone Dosi

    I don’t have the lib in the folder (I don’t have the folder ProjectName/Libraries/Plugins/iOS but only the ProjectName/Libraries/Plugins/FMOD folder).
    I use Unity 2017.1.1p1, i’ve got the version 1.09.01 of FMOD Unity Integration and i have installed FMOD Studio 1.09.02.

  • Cameron Baron

    It looks like you are missing the iOS libs.
    Re-import the FMOD Unity Integration into the project, then double check the settings by selecting the lib I mentioned in the ‘Project’ window and make sure the correct boxes are checked for deploying to iOS.

    View post on imgur.com

  • Simone Dosi

    With imported libraries can i use Unity Audio with FMOD Audio on iOS?
    Or there’s not a workaround for this big issue?

  • Cameron Baron

    Unfortunately due to Unity’s inbuilt audio being an old version of FMOD, if it is not disabled on iOS you can run into a number of issues.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.