Answered
0
0

When I import the unitypackage for updating to FMOD 1.10.01 all the reference of the FmodGvrAudioRooms are lost. I can re-add manually every room, but I lose all my settings…

I got this message right under the missing script reference: “The associated script cannot be loaded. Please fix compile errors and assign a valid script.”
Here a screenshot of the message i got in the editor the unity editor:
http://it.tinypic.com/r/2vczwjk/9
I dont have any compile error and the script goes missing right after the unitypackage is imported.

Is this some sort of bug? Do I have to wrap that class to manage all the parameters and avoid this sort of error?

Thanks for yous support,
Simone

  • You must to post comments
Best Answer
0
0

It looks like the guids in the meta files of the FMOD/GVR scripts are being overwritten.
We are working with Google to add the meta files to the plugins.

One workaround would be: when importing the new FMOD package, deselect the FmodGvrAudioRoom and Editor scripts as they do not require updating, only the FmodGvrAudio.cs file needs to be updated.

Another would be to copy the meta files for the FMOD/GVR files from your original project and copy them back in after updating the plugin.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.