0
0

I’ve followed this

https://fmod.com/resources/documentation-api?page=content/generated/engine_ue4/sequencer.html#/

To a tee and it does not work.

I can’t seem to SPAWN and Play FMOD events by using the Drag and Drop method.

I can only use them if they are already in the level and being “borrowed” by the Sequencer.

This is problematic, because when our scenarios load, the levels unload and with it the FMOD event.
I wanted to load specific FMOD events in the Sequencer.

UE 4.17 and FMOD 1.9.08

No matter what I do, I can’t seem to get an event to Spawn and play inside of the sequencer. Has anyone done this yet?

  • You must to post comments
0
0

I’m not having any issue spawning objects in the sequencer.

These are the steps I used:
– Add new level sequence
– Search for ‘FMOD Ambient Sound’ in the Modes window
– Drag the FMOD Ambient Sound into the Sequencer window
– Uncheck the ‘Spawned’ checkbox and add a keyframe
– Move the Sequencer timeline cursor forward 50ms
– Check the Spawned checkbox (that should automatically add a new keyframe)
– Select the Level Sequencer in the scene and check ‘Auto Play’
– Hit play

Are you getting any warnings or errors at all?

  • JB
    • JB
    • 6 months ago

    I tried exactly what you did numerous times and I do not hear any sound being played.
    -Added FMOD Ambient Sound
    -Drag Into Sequencer window

    —-Now, I’m not sure how you got a sound to play without setting any event on the FMOD Ambient Sound in the details pane. So I changed it to my FMOD Event “Crowd Loop”

    -Unchecked Spawned checkbox and add keyframe
    -Moved the timeline cursor forward 50ms, 5ms, 100ms, doesn’t seem to make a difference
    -Check spawned box and automatically added new keyframe

    -Level Sequencer in the scene, I could not find the level sequencer in the scene to find “Auto Play” unless I use the “FMOD Audio component0” that gets created. But I have to add that to it’s own track, which is a bit different than what your instructions were…

    I’m still having no luck with this…

    Here’s a screenshot from before I figured out that I had to add an FMODAudioComponent to the sequencer timeline before being able to see “Auto Play”

    https://www.dropbox.com/s/ryy7umbwkfjmzpq/FMOD%20Sequencer%20issue.PNG?dl=0

  • Cameron Baron

    Apologies, I did miss the step where I set the FMOD Event in the details pane in the list.

    The Auto Play option you are seeing there is for the FMODAudioComponent, I was talking about the one that controls the Auto Play option of the Sequencer, there should be a Sequencer object either in the scene or in the content browser you can select to view and edit settings.

    Is it not playing when you try to audition/test the sequence in editor or when you use Play-In-Editor?

  • JB
    • JB
    • 6 months ago

    That’s correct. I ended up finding a solution a different way though.

    I just loaded the FMOD Event into the level and turned them all off of Auto Activate and just have them waiting for the scene to activate/deactivate them.
    That seems to be the only way I can get it to work.

    When I try to spawn into the scene and play, I can never get it to work…

    I’m gonna come back at this later this week and I’ll let you know what I end up doing. Thanks for the help so far!

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.