Answered
0
0

UPDATE: THANKS, IT IS FINALLY WORKING!
I added the plugin .dll into the binaries folder and also made a plugin.txt with ‘resonanceaudio’ as @holley gray suggested.
In UE4
– disabled the built-in Resonance Audio plugin
– in Project settings/Platforms/Audio, I put everything back to Built-In..
– in Project settings/Plugins/FMOD Studio/Advanced/Plugin Files, I added ‘resonanceaudio’

Hi! Kind of a noob here so please bear with me, but this issue is driving me crazy and can’t seem to be able to solve it.
Is there a video or a basic step by step guide anywhere to implement VR audio in UE4, except those incomplete manuals?

What I did so far:
– added a listener (GVR or Resonance) on master bus
– added source (tried both GVR and resonance) on tracks
– in UE4 4.19 enabled Resonance plugin and in Project settings/Platform changed Spatialization plugin and Reverb plugin to Resonance (the Occlusion plugin only has the option for built in)
..and I don’t get any sound.

Can anyone help please, I just want to be able to get any sound out of my HMD :)
Am I missing something or not setting something up right?
This project is supposed to work on Oculus and Vive (I have Oculus for testing) and I don’t care what I use as long as it works, just used Resonance as it was there already.

-the sound works in FMOD studio

Sorry for being kind of incoherent but it’s really driving me crazy and I can’t seem to find any relevant resources.

Cheers

  • You must to post comments
Best Answer
1
0

Glad you managed to get it working, we have some docs that cover this:
https://fmod.com/resources/documentation-api?page=content/generated/engine_ue4/plugins.html#/

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.