Answered
0
0

Hello,

This could be a bug with Android builds (FMOD Studio Unity 1.09.03 & Unity 5.5.2f1). No problems with stand-alone & iOS builds.

I have single events using up to 8 audio tracks and I use Studio::Bus::setMute to mute/unmute the audio tracks individually. For longer loops inside the event (>10 seconds) when muting those tracks quickly in succession they get out of sync in Android builds (tested on multiple devices from 2014 to 2017).

Problem solved with Studio::Bus::setVolume, set to a very low value. This doesn’t cause any drift.

Of course it’s possible that I missed something from the docs …

  • You must to post comments
Best Answer
0
0

Hi Laurent

The problem here is that FMOD is making the audio tracks virtual when they are silent and virtual voices do not currently retain sample accuracy. We are working on keeping virtual voices sample accurate but in the meantime there are two workarounds –

  1. Setting the event priority to highest
  2. Setting the volume to a very low value, as you’ve discovered

Both of these workarounds prevent FMOD from virtualizing voices. We recommend setting the event priority to highest as the preferred workaround.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.