0
1

Hi,

I’m trying to make anim notify sounds be affected by occlusion settings.

I opened AnimNotify_FMODPlayEvent (concluded in fmod studio plugin content),
And I added a node – ‘Set Attenuation Settings’ – between Play Event Attached and Return Node on the Function ‘Received Notify’.

It Works In Game. Every events triggered on FMOD notifies have occlusion effect.

However, a fatal problem is occured.

At animation preview, Engine trying to play an FMODNotify, And Unreal Editor shut down.

I just want to ‘do not shut down at the animation preview,
AND affect events triggered at notify my attenuation setting for occlusion – Just in game.

How can I fix it?

enter image description here
enter image description here

  • Geoff Carlton

    Be careful not to mix up the inbuilt AudioComponent to the FMODAudioComponent, they are two different things!

  • Howu

    Hi Scott,
    You should use Class/FMODAudio Component/ Set Attenuation Settings, DO NOT use class/Audio Component/ Set Attenuation Settings.

  • Scott Rosenkrantz

    Hey Howu, where do you find this? It’s not in my list of nodes for FMOD. Are you on 4.12?

  • Howu

    Scott, Uncheck ‘Context Sensitivity’ and type “FMOD Set Atte~~”, or unfold directory ‘class’, ‘FMOD Audio Component’

  • Scott Rosenkrantz

    Ok turns out I was using an older fmod/ue4 integration than the one that contains the FMOD Set Atte~~ nodes. Downloaded the 010804 Integration and they’re there now. Cheers!

0
0

I set up something similar and I don’t see a crash at this end. Could you create a small UE4 repro project and send it to support@fmod.com?

  • You must to post comments
0
0

Thanks, Geoff Carlton.

I’ll send you an email with some essential files for this test.

And, I’ve just found a hint.
Animation preview shut down when the FMOD Notify use bone name.
If bone name parameter is empty, this error doesn’t occur.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.