Answered
0
0

Hello,
I’m having the following errors in the WIN 32 or 64 packaged project (log file):

Warning: Failed to load strings bank: ../../../PlanetAlpha31/Content/FMOD/Desktop/Master Bank.strings.bank

Error: c:\jk\workspace\Build__1.7__UE4Libs_Win\studio_api\src\fmod_bank_loader.cpp(66) – Failed to open file ‘../../../PlanetAlpha31/Content/FMOD/Desktop/Master Bank.bank’

Error: c:\jk\workspace\Build__1.7__UE4Libs_Win\studio_api\src\fmod_bank_loader.cpp(66) – Failed to open file ‘../../../PlanetAlpha31/Content/FMOD/Desktop/Master Bank.strings.bank’

Warning: Failed to bank: ../../../PlanetAlpha31/Content/FMOD/Desktop/Master Bank.bank (File does not exist)

Warning: Failed to bank: ../../../PlanetAlpha31/Content/FMOD/Desktop/Master Bank.strings.bank (File does not exist)

This prevents any audio from being played in the packaged project.
Windows 10, UE 4.10.2, FMOD Built/DLL Version: 1.07.06, FMOD Studio: 1.07.06, Build #71893

It works fine in the editor and it works fine if I launch the project.
I’m a bit under pressure since I need to deliver a build tomorrow so I hope I can get some help here.

Thank you,
-Adrian

  • Adrian Lazar

    Update:

    I cooked the project without the use of Pak files and indeed, the FMOD folder was missing.
    Copy pasting the folder from the UE editor content did the trick and audio works and now I added the FMOD folder to the Additional Non-Asset Directories to Package in Packaging settings and the folder is being copied automatically.

    Not sure what happened because I never had to do this before but it works now and I can have my build ready in time.

    Best,
    -Adrian

  • You must to post comments
Best Answer
0
0

You’ll definitely need to add FMOD to the Additional Non-Asset Directories to Package, as mentioned here:

http://www.fmod.org/documentation/#content/generated/engine_ue4/deployment.html

I’m not sure about the copy folder that you also mentioned, you shouldn’t need to copy the FMOD folder around manually.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.