Answered
0
0

Hello,

In the latest stable branch 4.44.57 you’ve added iOS SDK9 support, but it seems that bitcode support wasn’t enabled.
When we’re trying to build an app with new version of the lib, we get this error:

ld: ‘fmod/ios/4.44.57/lib/libfmodex_iphoneos.a(fmod_output_coreaudio_objc.o)’ does not contain bitcode. You must rebuild it with bitcode enabled (Xcode setting ENABLE_BITCODE), obtain an updated library from the vendor, or disable bitcode for this target. for architecture arm64

Do you have the version of the lib with bitcode included?

Regards,
Max

  • You must to post comments
Best Answer
1
0

This is a great question, probably one a lot of developers have. I’m going to take this opportunity to make an official statement on Bitcode, and publish this post as a FAQ.

Once Bitcode has been added to a library it is a requirement that developers use Xcode 7, Xcode 6 will not understand the Bitcode binary and will fail if attempted to link. While Apple permits the submission of applications to the store using Xcode 6 and does not require Bitcode we intend to leave the current stable FMOD Ex 4.44.xx branch without Bitcode support. This will ensure maximum compatibility for existing developers.

As Bitcode seems to be the future of iOS we have enabled support for it in our latest FMOD Studio 1.07.xx release (1.06.xx will remain without Bitcode for compatibility).

We encourage all developers of new applications to move to FMOD Studio to receive the latest features and optimizations for all platforms. FMOD Ex is a legacy product, while still maintained for bug fixes it will not receive non-essential functionality.

As of the date of this post it is not a requirement to submit to the app store with Bitcode enabled. Disabling Bitcode for your project will not affect your title in any way. If it becomes a requirement we will update the FMOD Ex release to include it.

  • You must to post comments
0
0

Thank you so much for your answer, Mathew!

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.