0
0

I keep running into this issue….

BankLoadException: FMOD Studio could not load bank ‘C:\Users\Madgod483\Desktop\KnossosSound\Build\Desktop/Master Bank.bank’ : ERR_PLUGIN_MISSING : A requested output, dsp unit type or codec was not available.
FMODUnity.RuntimeManager.LoadBank (System.String bankName, Boolean loadSamples) (at Assets/Plugins/FMOD/RuntimeManager.cs:631)
FMODUnity.RuntimeManager.Initialiase (Boolean forceNoNetwork) (at Assets/Plugins/FMOD/RuntimeManager.cs:287)
UnityEngine.Debug:LogException(Exception)
FMODUnity.RuntimeManager:Initialiase(Boolean) (at Assets/Plugins/FMOD/RuntimeManager.cs:291)
FMODUnity.RuntimeManager:get_Instance() (at Assets/Plugins/FMOD/RuntimeManager.cs:79)
FMODUnity.RuntimeManager:SetListenerLocation(Int32, GameObject, Rigidbody2D) (at Assets/Plugins/FMOD/RuntimeManager.cs:850)
FMODUnity.StudioListener:SetListenerLocation() (at Assets/Plugins/FMOD/StudioListener.cs:42)
FMODUnity.StudioListener:OnEnable() (at Assets/Plugins/FMOD/StudioListener.cs:21)

I’m following the instructions that my teacher has given me but yet it will not work for my environment, I have the FMOD Studio Listener attached to my main camera and have the FMOD Studio Event Emitter attached to the fire particle effect, but am still unable to get it to produce any sounds…

  • You must to post comments
0
0

Ok, Thanks i’ll check that out.

Appreciate the help :)

  • You must to post comments
0
0

Hello Joshua,

It looks like you are missing a plugin from the FMOD Studio project itself. Because of this it cannot load the bank and therefore cannot find the bus.

It would be best to consult your teacher if you’re following instructions from them as they may have asked you to use a custom or a trial plugin.

Thanks,
Richard

  • You must to post comments
0
0

@ Richard

FmodHelpPictures

I’m sorry, i’m not sure what you are talking about… I have tried taking your suggestion and talk with my teacher about it, but I have not yet received a response back from him.

On my Unity console it keeps showing the RuntimeManager.cs (i’m not sure if it is related to the issue) and I was able to find it when searching for that script. I got the latest version of the Fmod to Unity Integration from the website here.

Could it be that I need to download an older version of the plugin?

Thanks,

Joshua

  • Richard Simms

    Hi Joshua,

    Without seeing the error logs in full and FMOD Studio project it’s hard to say. You will need to use the Unity Integration that matches your copy of FMOD Studio. The latest FMOD Studio is 1.09.04 but if you’re using an older version you will need to browse through the previous versions to match.

    The RuntimeManager.cs file is just what FMOD uses to initialize and interact with the FMOD Studio banks.

    Thanks,
    Richard

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.