Answered
0
0

I’m currently trying mitigate a memory issue. When i play the game from designer it uses 127 megs. I’ve opened the session in Studio and now the game uses 827 megs. My assumption is that the streaming sounds are NOT being streamed. Disk usage looks to be 0%
How do i know if sounds are being streamed?
screen cap

  • You must to post comments
Best Answer
1
0

Open up the Asset Browser and view the file. Or you can right click on the file in the timeline and say “Open in Asset Browser”.

Once the sound file you selected is highlighted, look at the bottom of the asset browser window and you’ll see “Click to add custom platform encoding setting” and to the right of that you’ll see something that says, “Loading” then “STREAM”.

That’s pretty much where all of it is handled.

You can also go to Preferences -> Build -> Desktop and adjust your general settings there.

  • Joseph Harvey

    As JB says, whether or not an asset is streamed is indicated in the assets browser; If the blue ‘STREAM’ tag appears, the asset is streamed.

  • You must to post comments
-1
0

Thanks for your reply JB. I’ve made those settings but there’s something else amiss here

  • JB
    • JB
    • 3 weeks ago

    Honestly, it is probably just simply a problem with how FMOD Studio handles the way your event in Designer is set up. I had to migrate a HUGE project from Designer to Studio last year and I had to redesign about 90% of my events… I was even working with an FMOD Programmer who handles the migration tool and well, to this day there are still problems we weren’t able to overcome.

    I’m not sure without actually seeing your session. You’re probably going to need help from one of the FMOD guys on this one, as it could be a million different things causing that issue.

  • Joseph Harvey

    @Dan Have you tried looking at your project’s performance in the Profiler window? It contains a number of tools for identifying where and how resources are being consumed.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.