I’m getting the following error when I try to run a project un Unity using the FMOD plugin. However, this only happens when working with a Unity project I downloaded–I’ve got a couple tutorial projects, including one from the Unity site itself. I am able to use FMOD successfully on a project I created myself.

I’ve tried using the newest FMOD plugin package, as well as the older one that I imported when I started my still functional project, a few months ago (fmodstudio10508). Any ideas what’s going wrong?

Also, can someone confirm whether or not FMOD should work with the free version of Unity? I saw another thread about license errors and followed the instructions to eliminate them, but I get an error message when I got to About Integration saying I need Unity 4 pro or Unity 5. Any help would be much appreciated.

I’m on Mac OSX 10.8.5, Unity 4.6.

DllNotFoundException: fmod
FMOD.Memory.GetStats (System.Int32& currentalloced, System.Int32& maxalloced, Boolean blocking) (at Assets/Plugins/FMOD/Wrapper/fmod.cs:1617)
FMOD.Memory.GetStats (System.Int32& currentalloced, System.Int32& maxalloced) (at Assets/Plugins/FMOD/Wrapper/fmod.cs:1612)
FMOD.Studio.UnityUtil.ForceLoadLowLevelBinary () (at Assets/Plugins/FMOD/FMOD_StudioSystem.cs:105)
FMOD_StudioSystem.get_instance () (at Assets/Plugins/FMOD/FMOD_StudioSystem.cs:146)
FMOD_Listener.LoadPlugins () (at Assets/Plugins/FMOD/FMOD_Listener.cs:219)
FMOD_Listener.Initialize () (at Assets/Plugins/FMOD/FMOD_Listener.cs:162)
FMOD_Listener.OnEnable () (at Assets/Plugins/FMOD/FMOD_Listener.cs:23)

  • You must to post comments
Best Answer

1.06.00 and onwards no longer work with Unity 4 Free. It required Unity 4 Pro, or any version of Unity 5.

  • just a guy
    Thanks for the confirmation. Also, I've found that if I import the FMOD package into a Unity project and setup the FMOD_Listener before importing the assets of the tutorial project, everything works fine. If I do it the other way around I get the error. No idea why, but for now the issue is resolved. I'll likely upgrade to Unity 5 in the semi-near future.
  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.