Answered
0
0

Hi !

I update my unity package and my soundbank with the last version of FMOD (1.05.00).

When i try to compile on xCode (with all cache clear), i have a compile error :

Undefined symbols for architecture armv7:
“_FMOD_Studio_VCA_IsValid”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Studio_EventDescription_IsValid”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Studio_System_IsValid”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Studio_EventInstance_IsValid”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Studio_EventInstance_CreateSubEvent”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Studio_Bus_IsValid”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Studio_Bank_IsValid”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Studio_ParameterInstance_IsValid”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Studio_CueInstance_IsValid”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o
“_FMOD_Debug_Initialize”, referenced from:
RegisterMonoModules() in RegisterMonoModules.o

I try to delete all of my FMOD files in unity and reimport the package (to have a clean import) but i still have the error.

I tried to download an older package (1.04.07) and compile on xCode. There was no error but i didn’t have any sound (maybe because of my soundbank version).

Is it a bug of FMOD 1.05.00 or i made an error somewhere ?

Thanks !

  • You must to post comments
Best Answer
0
0

Thanks for the report, part of the iOS build system for Unity hadn’t been updated for some API changes. Here is prerelease package of 1.05.01 which resolves this issue:

ftp://upload:upload@ftp.fmod.org/fmodstudio10501_prerelease.unitypackage

Apologies for the inconvenience.

  • You must to post comments
0
0

Hello !

I have no error with this package.

Thanks a lot !

  • You must to post comments
0
0

I have the same problem, bug I can not download the site, would you send the unitypackage to my e-mail?

  • You must to post comments
0
0

I also has the problem, and I can’t download package from the site, please send the package to my-mail, thanks.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.