Answered
0
0

After converting our audio project to the latest release of FMOD Studio 1.10 a 3D audio event has begun acting strangely.

It can only be played once, both in FMOD Studio itself, and in UE4 (Which we’re using). After that, it won’t perform any additional playbacks. The audio event is a one-shot, not having any looping components. Just a linear timeline with a few tracks layered and a single parameter, that adjusts some of the volume levels for the tracks.

Other events can play without problems both before and after this.

What’s even stranger is, that the faulty event cant be removed. I’ve recreated the audio effect in a new event, which works as expected, but when I try to delete the old faulty event, FMOD studio just crashes.

Any ideas, how to get rid of this faulty event, and if there is anything we can do in the future to avoid similar instances?

  • You must to post comments
Great Answer
1
0

Hello Jesper,

Regarding your event that will only play once – does it have an event cooldown? On the master track at the bottom right of the deck there should be a “Cooldown” property. Please try setting this to 0.00ms and see if it can play again. We have a fix in our next release for this issue.

In regards to your project crashing when deleting this event, do you get the crash report screen when it crashes? If so, could you send it through to us and bring attention to this Q&A.

Thanks,
Richard

  • You must to post comments
0
0

Hi Richard.

The event did have a cooldown period of 200ms. Turning it down to 0 fixed the issue. Both with playback and being able to delete the event.

Thanks for the assistance!

Jesper

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.