Answered
0
0

Here’s the situation
1) FMod and UE4 are working together. in WASAPI (shared audio mode) everything is great. Sound works 100%.

2) When I switch to ASIO audio in Fmod preferences (using ASIO4ALL drivers), the sound works in FMod, but not in Unreal. Even when there’s a live update connection.

So if I open an event in fmod, and press play, I can hear it. But when I run the game in the ue4 editor, and create a live update connection, there is no sound. As soon as I switch to WASAPI, everything is fine again.

Any idea how to make this work? I’m trying to make a low-latency audio game.

  • You must to post comments
Best Answer
0
0

When a program uses ASIO it takes exclusive control of the sound device. So running FMOD Studio (or any app for that matter) with ASIO will mean your game won’t have audio. Your only option here is either a) don’t use ASIO or b) use ASIO with one sound card / device, run the game with ASIO (or WASAPI) using a second sound card / device.

If you’re looking for low latency, I would recommend using WASAPI, use System::setDSPBufferSize to reduce your latency to a buffer size of 512 and buffer count of 4 (or 2 if carefully tested). This will require 1.08.xx to get stable results.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.